Problem with Property Management database error


(Bernie ) #1

Hi

When I try to view a room list report, I have an error
"File:/var/www/html/admin/modules/pms/Pms.class:php:5505.
This was caused when doing a maid service in one of the room, multiple times.

I try removing PMS and reinstall, but it is still the same.

If anyone can help me, that will be great.

Bernie


#3

Do you know your way around a SQL database? If so, take a look at the table that gets created when the module is installed, it is probable that the table is not removed when the module is uninstalled. But I guess you could also contact sangoma support, as PMS is supposed to be a commercial module if I recall correctly.


(Bernie ) #4

Thanks Arielgrin

I am not good with sql. I will try to look at it and delete the table. I am using the non-supported module part of the commercial module since, we are under a small establishment under 10 rooms.

Thanks

Bernie


(Franck Danard) #5

Hi.

There’s a bug indeed when you try to enter a wrong service number.
E.g: If you configure 4 services: 01, 02, 03, 04 and you try to dial *4405, you’ve got this issue.

Check asterisk database like this in CLI.
CLI> database show service

Remove service like this
CLI> database deltree service

By the way, I will update property management for avoid to get this error in the futur.


(Franck Danard) #6

I fixed that.
Now we are not able to enter any uknown code. If the code doesn’t exist, the call is canceled or ask to enter a code again.
If the code is messed up for any reason, it will be removed.
Also I fixed the fact when we uninstall SPM, the data in asterisk db are removed as well.

Wait the publishing and new release (edge or stable).


(Bernie ) #7

Hi danarf

Thanks for the advise. It works now after deleting the service tree.

Bernie


(Franck Danard) #8

You’re welcome :wink:


(Franck Danard) #9

New version published on edge.


(Bernie ) #10

Thanks Franck for the quick fix. I will try it out to see if there are any more errors.

Bernie


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.