Problem with parking lot timeout

FreePBX v2.3.1.0
Asterisk 1.2.23
P4 3.0Ghz, 1Gb RAM, 3ware SATA RAID, Digium Wildcard TE110P

Parking a call, retrieving a parked call, and destination for orphaned calls works just fine. But, if we change the “Parking Timeout” it still leaves the caller in the parking lot for approximately 45 seconds before sending them to the orphaned call destination. We tried bumping that time up to 1 minute 30 seconds, then 5 minutes, then 10 minutes but after 45 seconds they are still sent to the orphaned call destination after 45 seconds.

There are no other weird timing issues on the server that we are aware of. As a test we set the ring time on an extension to 2 minutes and an inbound call rang for approximately 2 minutes then was sent to voicemail.

Anyone else having this issue or know how to fix it?

check to make sure you have not redefined the information in features.conf and overrode the info set by the module

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

features.conf has an include for, two references to features_ files that do not exist, and the feature map for blind xfer, disconnect and automon. The is as follows:

parkext => 70
parkpos => 71-79
context => parkedcalls
parkingtime => 600

This appears to have been created by the parking lot module since the time shows 600 seconds.

the parking module creates that and the 600 seconds comes from you setting it to 10 minutes. This value should take - I don’t believe there is any issue setting it this high.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

We don’t want to set it this high, we’d be happy if we could get 1.5 minutes. The 10 minutes setting was just something we tried to see if we bumped the time up considerably if it would make a difference or not, which it didn’t. Regardless of what we set the time to it still kicks the user out of the parking lot after 45 seconds.

I guess there is no solution to this problem. Thanks for your help.

changing the parking time does work. I can’t say what is going on with your system but I can say that I can make changes to the parking time and the changes take effect. It has been a while since I messed with the parking. It could be that you need to restart Asterisk or at least reload in the CLI. The reload may not be adequate.

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx