Problem with Paging and Intercom

I’m having trouble getting my paging to work correctly. I have 33 Linksys SPA962 phones that are all part of a paging group. Whenever I page the group several of the phones are not receiving the page. I’ve compared all the phone settings and they all appear to match.

One thing I’d like to check is to see if paging is enabled for a particular extension. I haven’t been able to figure out how to see this within FreePBX or maybe within asterisk. I could physically go to each phone and dial *54 to enable paging but I’d like to see a list of who has paging enabled and who doesn’t.

The phone system I’m dealing with is in a school so it’s hard for me to do a test whenever I want so I want to at least try to identify what the problem is before running another test.

One thing I’ve noticed but I’m not sure if it’s related is the extensions that aren’t getting the page are the ones who read unread voicemail in their inbox. I’m not sure how that would have an affect on paging.

I’m not sure if I’ve provided enough information that would be helpful but I appreciate any help that would point me in the right direction. Thanks.

On FPBX *54 writes “intercom=disabled” to the internal asterisk database to disable paging for certain extensions. From what I remember if “intercom” is set to enabled, or not defined, then paging is available for that extension. If you have shell access try running this command:
asterisk -rx “database show AMPUSER” | grep “intercom”

And see if there are any lines that say “disabled”. If so, those extensions are set not to page/intercom. Hope that gives you somewhere to start at least…

Another question comes to mind…can you do a *80 intercom to those phones?


I ran asterisk -rx “database show AMPUSER” | grep “intercom” and only two extensions are showing up. This made me realize I forgot to mention that I’m running in user/device mode. Not sure if that has an effect. I decided to do a *54 on another phone and then run the command again and it is now showing up. Do you think I need to do a *54 on all the phones?

Also, it appears that *80 is not working at all. I tried to do a *80 and I get a busy signal before I can even try to enter the extension to page.

You have a dial plan issue on your phones if you can’t dial *80+ext

I tried your command: asterisk -rx “database show AMPUSER” | grep “intercom” None of my extensions showed up! Were they supposed to?