Problem with my freepbx I can not use the distro or format (distro is installed in a corsair voyager 8gb)

HI my freepbx (centos 5.2 version) was working fine,
but now when it boot they load fine but when arrives to check file system

it appears

INIT: cannot execute /sbin/mingetty
ext3_abort called
ext3-fs error (device DM-0): ext3_journal_start_sb:detected abroted journal
remounting filesystem read only

respawning too fast: disable for 5 minutes this appears like 10 times

a) distro can not load
b) i don,t know how to make a fsck plus I can not login as root
c) I tried to reinstall freepbx inside the box but it said no enoght space
d) I tried to format in windows xp but (is a usb stick istall 8gb) it is detected but show 0 space and, it only show 100mb for format (boot)
f) I tried to format with acronis suite in windows xp. it is detected but it is said that the usb stick is write protected, but usb stick has not any turn on/off for write protected, so it appears as write protected but is not at hardware level i suppouste is linux that protect the file

  1. how I can run fsck to try to fix the file system
  2. how I can make the usb stick allow to write or format ?
  3. If I could format the usb stick would be better

thanks for your help
a desperate freepbx user

Sounds like the USB stick is corrupted, maybe not recoverable. Have you tried another USB thumb drive?


HI. the USB can boot but it appears that is cycling, the usb works fine but it stuck the distro said that is remounting fylesystem read only. maybe that is the read only that make write protected. I was looking to some command that make me to quit write protected and then procced with the format or a command that allow me to do a fsck before it arrives to check filesystem

well the problem is the usb stick If I put another usb stick be sure that new wont have that problem