Problem with inbound routing on a T1 line

I am having an issue with inbound routing for a T1 line. I set up the last four digits as the inbound router and pointed it to an extension. However when I call the number is says cant be completed as dialed. Here is the log:

Executing [[email protected]:1] ResetCDR(“DAHDI/i1/XXXXXXXXXX-14”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“DAHDI/i1/XXXXXXXXXX-14”, “”) in new stack
– Executing [[email protected]:3] Progress(“DAHDI/i1/XXXXXXXXXX-14”, “”) in new stack
– Executing [[email protected]:4] Wait(“DAHDI/i1/XXXXXXXXXX-14”, “1”) in new stack
– Executing [[email protected]:5] Progress(“DAHDI/i1/XXXXXXXXXX-14”, “”) in new stack
– Executing [[email protected]:6] Playback(“DAHDI/i1/8XXXXXXXXXX2-14”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
– <DAHDI/i1/8482107702-14> Playing ‘silence/1.gsm’ (language ‘en’)
– <DAHDI/i1/8482107702-14> Playing ‘cannot-complete-as-dialed.gsm’ (language ‘en’)
– <DAHDI/i1/8482107702-14> Playing ‘check-number-dial-again.gsm’ (language ‘en’)

That is the log of an outbound call that can’t complete , Start off by calling your DID from an external phone.

That is a call from an external phine to the DID. I dont know why it is coming up ad from-internal

It is the context you defined for that trunk and should probably be from-did-direct to map your last-four directly to an endpoint or from-trunk depending on what you want.

Here is the dahnd_channels.conf
; Autogenerated by /usr/sbin/dahdi_genconf on Fri May 22 17:48:06 2015
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: R2T1/0/1 “R2T1 Card 0 Span 1” (MASTER) ESF/B8ZS RED
group=0,11
context=from-pstn
switchtype = national
signalling = pri_cpe
channel => 1-23
group = 63

; Span 2: R2T1/0/2 “R2T1 Card 0 Span 2” ESF/B8ZS RED
group=0,12
context=from-internal
switchtype = national
signalling = fxo_ls
channel => 25-47
context = default
group = 63

; Span 3: R4T1/1/1 "R4T1 Card 1 Span 1"
group=0,13
context=from-internal
switchtype = national
signalling = fxo_ls
channel => 49-71
context = default
group = 63

; Span 4: R4T1/1/2 "R4T1 Card 1 Span 2"
group=0,14
context=from-internal
switchtype = national
signalling = fxo_ls
channel => 73-95
context = default
group = 63

; Span 5: R4T1/1/3 "R4T1 Card 1 Span 3"
group=0,15
context=from-internal
switchtype = national
signalling = fxo_ls
channel => 97-119
context = default
group = 63

; Span 6: R4T1/1/4 "R4T1 Card 1 Span 4"
group=0,16
context=from-internal
switchtype = national
signalling = fxo_ls
channel => 121-143
context = default
group = 63

I now have them showing as from trunk, except for the firstchannel for some reason that is still showing as from-internal

Well that’s all a little screwed up :slight_smile:

There is no default context in FreePBX

For RBS signaling (fxo_ls included and presumably a channel bank) there are 24 channels per span not 23 and wrong switchtype

Everything is in Group 0 (and 63) and probably shouldn’t be for proper routing.
.
.

I would start over possibly without the FreePBX dahdi helper module involved if you ever did.

http://www.voip-info.org/wiki/view/DAHDI

when /etc/dahdi/sytem.conf and /etc/astererisk/dahdi-channels.conf agree as to mapping channels it should work,