Problem with Inbound routes


#1

Greetings people .

I am experiencing a weird issue, so far I have been able to correctly configure asterisk through free pbx 2.0 for the outbound calls .
Unfortunately looks like inbound calls are not working at all .

Here I would like to post the last lines of the debug messages .

/****************** START ****/
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
############
– Executing [############@from-pstn:1] Set(“SIP/############-00000005”, “__ FROM_DID=############”) in new stack
– Executing [############@from-pstn:2] NoOp(“SIP/############-00000005”, “R eceived an unknown call with DID set to ############”) in new stack
– Executing [############@from-pstn:3] Goto(“SIP/############-00000005”, “s ,a2”) in new stack
– Goto (from-pstn,s,2)
– Executing [s@from-pstn:2] Answer(“SIP/############-00000005”, “”) in new stack
– Executing [s@from-pstn:3] Wait(“SIP/############-00000005”, “2”) in new s tack
– Executing [s@from-pstn:4] Playback(“SIP/############-00000005”, “ss-noservice”) in new stack
– <SIP/############-00000005> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [s@from-pstn:5] SayAlpha(“SIP/############-00000005”, “############”) in new stack
– <SIP/############-00000005> Playing ‘digits/3.ulaw’ (language ‘en’)
– <SIP/############-00000005> Playing ‘digits/9.ulaw’ (language ‘en’)
– <SIP/############-00000005> Playing ‘digits/6.ulaw’ (language ‘en’)
– <SIP/############-00000005> Playing ‘digits/8.ulaw’ (language ‘en’)
== Spawn extension (from-pstn, s, 5) exited non-zero on ‘SIP/############-00000005
– Executing [h@from-pstn:1] Macro(“SIP/############-00000005”, “hangupcall,”) in new stack
– Executing [s@macro-hangupcall:1] GotoIf(“SIP/############-00000005”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [s@macro-hangupcall:3] ExecIf(“SIP/############-00000005”, “0,Set,CDR(recordingfile)=”) in new stack
[2012-09-13 17:28:47] WARNING[13120]: app_exec.c:231 execif_exec: Deprecated syntax found. Please upgrade to using ExecIf(?Set(CDR(recordingfile)=))
– Executing [s@macro-hangupcall:4] Hangup(“SIP/############-00000005”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/############-00000005’ in macro ‘hangupcall’
== Spawn extension (from-pstn, h, 1) exited non-zero on ‘SIP/############-00000005
/
END ******************************/

Where ############ is the SIP trunk.

I really thank anyone in advance for any kind of suggestion.

Fye


#2

You will have to set up an inbound route for ############ and make sure ########### is not excluded and if necessary allow anonymous inbound sip connections


#3

Hi .

Thanks for your answer .

I made the changing on my settings, but i 'm not solved it …

I just can’t wrap my head around getting this to work with FreePBX =( =( =(

My inbound is :

Trunk Name: 3968xxxxxxxx
Outbound CallerID?: the same

channel : 6

canreinvite=no
context=from-pstn
disallow=all
allow=g729&ulaw&alaw
fromdomain=84.253.131.12
fromuser=3968xxxxxxxx
host=84.253.131.12
insecure=very
qualify=no
secret=xxxxx-xx
type=peer
username=3968xxxxxxxx

INCOMING 3968xxxxxxxx_in

context=from-pstn
fromuser=3968xxxxxxxx
host=84.253.131.12
insecure=very
secret=xxxxx-xx
type=peerxxxxxxxx
user=3968xxxxxxxx
username=3968xxxxxxxx

REGISTER

3968xxxxxxxx:xxxxx-x@84.253.131.12:5060/3968xxxxxxxx

Please could you help me ?

Very thanks …

glad to have you visiting in Italy =D =D .

P.S= Anonimous mode in general setting = no !


How to troubleshoot "Failed to authenticate on REGISTER"
(system) closed #4