Problem with HT503 and FreePBX as Trunk

Please help with the HT503 configuration problem as a trunk for FreePBX. I’ve tried a lot of instructions. I attach the settings pictures on google drive. I do not even have incoming or outgoing calls.
IP HT503:
Please help. I’m really desperate.
thank you very much

I can not upload pictures or links, so please if anyone wants to help me contact me and send pictures to him.
email: tomas.marek(at)agentes-it(dot)com

Try this: Grandstream HT701 not connecting to pbx Please help

I have two HT702’s in two different locations (FreePBX servers). One has been running for years and the other I just reconnected to a new FreePBX box last week. Could not get it to connect until I did as suggested by this post.

Good luck.

1 Like

There are subtle issues with pjsip and devices with both FXS and FXO ports (such as Grandstream HT503 and HT813, Linksys SPA3000 and SPA3102 and Obihai OBi110 and OBi212), which are all pretty similar.

To start, please answer:

pjsip or chan_sip? Tried the other?
FreePBX and Asterisk versions?
Using FXS port?
What is the FXO port connected to (copper pair from Central Office, cable MTA, fiber ONT, analog port on ISP-supplied router, etc.)?
Does FXO port register ok?
If so, what happens on attempted outgoing call? Incoming call?

To post Asterisk logs, etc., paste them at , check the Create Shorturl box, click Create, note the 8 hex characters at the end of the URL and include in your post.

You were able to post an image here, I assume that you can post more if needed.

Most important thing is to point the trunk to the correct port, which is 5062 if you have not modified the default configuration.

Assuming the screenshot is accurate, the OP’s device is set to register to FreePBX, so any port setting in the trunk will be ignored. (That may not be the best approach, but first let’s see what his constraints are, before suggesting changes.)

I would also like to ask if the vehicle has been cut off if you can send a photo of a service book. I do not use Port FXS I only need it as FXO Trunk for FreePBX. On page HT503 shows SIP Registred. I have an entire configuration, but I can not give more than one photo as a new user. I will attach a link to google disk here:


You don’t need to use registration if you can’t figure it out, since your ht503 is on the same network as your freepbx, I guess you are not worried about security as your lan is correctly protected.

The pseudo-link you posted has only one image, showing call forward to VoIP.

You are registering to port 5060 (would be pjsip by default) but forwarding to port 5160 (chan_sip)?

Please describe your trunk settings, inbound and outbound routes.

Post the Asterisk log for an attempted outgoing and an incoming call.

Also describe what the caller hears, whether the called phone rings, etc.

Does the PBX otherwise operate correctly (can you call between extensions, make and receive calls on SIP trunk, etc.)?

Sorry for pics. Here is working url with configuration of freepbx and HT503. If you need more just ask me. Thank you very much for helping me.

URL: imgur(dot)com/a/1FY5dxw

Please try the following settings:

In FreePBX, for the trunk, set CID Options to Force Trunk CID (on an analog line, you have no control over CID).
Change host= to
and remove the port=5062 line.
The secret should consist of only letters and numbers and must exactly match what you enter into the Authenticate Password field for the FXO port.

Delete extension 387202832 altogether (only the trunk is needed).

Make sure that you have an Outbound Route that will send calls to your 503-1 trunk.

Restart Asterisk.

For the FXO port, set:
Primary SIP Server:
Outbound Proxy: (leave blank)
Number of Rings: 1
Stage Method: 1

After applying settings, wait a few seconds and check the Status tab. The FXO port should show as Registered. If not, we need to fix that first. If the registration attempts write anything to the Asterisk log post that.

If the FXO port is registered, try incoming and outgoing calls. If there’s trouble, report what you hear and post the Asterisk log for the failed attempts.

I set according to the instructions. HT503 shows NOT REGISTRED and Asterisk log coming in below. He writes the wrong password but the password is definitely correct. I tested other options.

[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action QueueMemberRingInUse
[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action QueueRule
[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action QueueReload
[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action QueueReset
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_VARIABLES’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_EXISTS’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_MEMBER’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_MEMBER_COUNT’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_MEMBER_LIST’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_WAITING_COUNT’
[2019-01-23 10:10:57] VERBOSE[2565] pbx_functions.c: Registered custom function ‘QUEUE_MEMBER_PENALTY’
[2019-01-23 10:10:57] VERBOSE[2565] loader.c: => (True Call Queueing)
[2019-01-23 10:10:57] VERBOSE[2565] loader.c: Loading
[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action DeviceStateList
[2019-01-23 10:10:57] VERBOSE[2565] loader.c: => (Manager Device State Topic Forwarder)
[2019-01-23 10:10:57] VERBOSE[2565] loader.c: Loading
[2019-01-23 10:10:57] VERBOSE[2565] manager.c: Manager registered action PresenceStateList
[2019-01-23 10:10:57] VERBOSE[2565] loader.c: => (Manager Presence State Topic Forwarder)
[2019-01-23 10:10:58] VERBOSE[2565] asterisk.c: Asterisk Ready.
[2019-01-23 10:15:23] NOTICE[2655] chan_sip.c: Registration from ‘<sip:[email protected]:5160>’ failed for ‘’ - Wrong password

When I try to make an incoming call, I only hear two fast beep sounds and the LINE lights up on the HT503 and goes out after a while, and when it rings out of the SIP phone via FreePBX it says All circuits is busy

Try the following trunk settings, which match what I have on an older system:

In the User Context, put from-trunk

In User Details, add:
secret=(same as in Peer Details)

Restart Asterisk, reboot the HT503 and see whether it registers. If not, at the Asterisk console, type
sip set debug on
and post the Asterisk log for a failed registration attempt.

Not working too. Here is my log file. When i try calling from freepbx to ht503 again said… All circuits are busy.

Now when I call the HT503, it will be connected to the PBX but FreePBX says Sorry, the collared number does not exist.

[2019-01-23 13:01:19] VERBOSE[6488][C-00000009] pbx.c: Executing [[email protected]:6] Log(“SIP/”, "WARNING,“Rejecting unknown SIP connection from"”) in new stack
[2019-01-23 13:01:19] WARNING[6488][C-00000009] Ext. s: “Rejecting unknown SIP connection from”
[2019-01-23 13:01:19] VERBOSE[6488][C-00000009] pbx.c: Executing [[email protected]:7] Answer(“SIP/”, “”) in new stack
[2019-01-23 13:01:19] VERBOSE[6488][C-00000009] pbx.c: Executing [[email protected]:8] Wait(“SIP/”, “2”) in new stack
[2019-01-23 13:01:21] VERBOSE[6488][C-00000009] pbx.c: Executing [[email protected]:9] Playback(“SIP/”, “ss-noservice”) in new stack
[2019-01-23 13:01:21] VERBOSE[6488][C-00000009] file.c: <SIP/> Playing ‘ss-noservice.ulaw’ (language ‘cs’)

There are two fields for the trunk name – I don’t know what each is used for. On my systems, a given trunk has the same name in both places. Do that for your trunk and confirm that the outbound route is using the common name.

Confirm that the HT503 now shows registered and the Asterisk Peers report shows the peer in OK status.

If you still have trouble, at the Asterisk console type
sip set debug on
and retry the outbound and inbound calls. Post the logs again, which will now include the SIP traffic to and from the HT503.

Thank you. So now the situation is the following. When I call, the incoming call picks up FreePBX. I have the echo test here. FreePBX speaks well but when I talk I can not hear it. And even if I’m redirecting to the extension and picking it up on my phone sip, communication does not work as if there was a bad codec or something. And the outgoing calls still do not work in the log they still write Wrong Password and no matching endpoint.

PS: Incoming calls, allowing Asterisk to accept unsecured calls.

Try using chan_sip without authentication for the trunk. Make sure you are not using lifeline feature on the ht503.
The configuration of the ht503 FXO port is quite simple.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.