Problem with external number in Follow Me list

I have an extension with Follow Me configured like this:

Initial Ring Time: 10
Ring Strategy: ringallv2-prim
Ring Time: 15
Follow-Me List:

After the initial ring time the call goes to Follow Me list as it should, but when the external phone starts to ring all other extensions (525 , 511) stop ringing. I assume this happens because when the trunk makes the call to the external number the system thinks the call has been answered. This is just my assumption.

I want all the extensions to keep ringing for the ring time (15) until someone actually answers the call, being this in the external phone ore an internal extension.

Thank you.

try ringallv2 only. this should work

It doesn’t work. To explain a little better the situation:

When someone calls the extension 525 it rings for the initial ring time (10), then it goes to Follow Me list, but in the moment the external number rings (a cellphone in this case) it stops ringing the other extensions (525 and 511). I can hear from the calling phone (some internal extension) how the ringing tone changes from the internal PBX to the trunk.

Thins occurs with or without “prim”.

I recall seeing reports about this in the past. The only solution I can remember is to make the cell phone a destination for the “on error” at the end of the FMFM. I think it’s because some carriers mark the phone call as “answered” at the remote phone as soon as the phone connects to the network. FreePBX does something similar with Fax detection by “answering” the call to see if there are FAX tones and letting the call fall through to the extension if there aren’t.

Another possible solution would be to make the cell phone an extension by assigning it a value through Misc Dest (IIIRC). This might not make any difference, but it does mean that the cell phone is now an extension rather than a remote destination.

I’m using POTS lines. They first connect to a FXO grandstream PSTN gateway, and then the gateway connects with the server through SIP trunks.

If you have another idea on how to solve this, please let me know.

I’d be willing to bet it’s the gateway doing a FAX check that’s causing the problem. Someone with more Grandstream Gateway experience may be able to offer more insight - I’m a SIP and SCCP guy.

I did some tests and it seems that the grandstream gateway is “answering” the call and sending the provider’s ring tone to the caller. This effectively makes the call as answered and stops ringing the other extensions.

I have another gateway which is used for GSM. If I use this gateway I don’t have the problem. The cell phone and the extensions ring at the same time. So, as a workaround I have created a special outbound route that is used only in the FM and prioritizes the GSM trunks.

I can’t tell what configuration needs to be changed in the grandstream gateway. I’m very lost there. Some grandstream guru??

The probes here is you are using pots the cannot determine when a call is answered. The call is considered answered when it’s starts ringing. To achieve what you want you need either a sip line from your provider or a digital line such as an Isdn. An analogue pots line will not cu the mustard.


As stated, the issue is the POTS line. Enable ‘confirm calls’ in the FMFM settings to overcome.

There is an option in the grandstream gateway (GXW4104) named “Enable Call Supervision”. If I enable this for all channels then things seem to work. Now the FMFM is ringing in the cell phone and extensions until someone actually answers the call. But the big problem here is that now the caller hears nothing, no ring tone, nothing until someone answers. Weird.

Looks nice, but I think it will add more complexity for my users, which could be external people.

There should be some other option in the granstream gateway that I’m missing. I will try my luck with grandstream support/forums/community.

Even if there is, I doubt it would work reliably. This is a fundamental limitation of POTS, there is no way to know when the far end answers.

1 Like

I tried all the tests, but the followme module does not transfer calls to me on an external number, the line hung up
can someone help me?
thank you

I found a solution
in outbound-route add 3 Trunk Sequence, Followme will use the Trunk Sequence 3.
if Trunk Sequence 1 and 2 are free, why do you skip to 3 trunk?
can you tell me how to divert followme on Trunk Sequence 1?