Problem with [ext-did-direct] (re-)generation

Firstly, I may misunderstand the source for the [color=blue][ext-did-direct][/color] and [color=green][ext-did][/color] generation.

I believe that [color=green][ext-did][/color] comes from the “Add Incoming Route” screen where the fields

ID Number
( Define the expected DID Number if your trunk passes DID on incoming calls. Leave this blank to match calls with any or no DID info. You can also use a pattern match (eg _2[345]X) to match a range of numbers)


Caller ID Number
( Define the Caller ID Number to be matched on incoming calls. Leave this field blank to match any or no CID info.:slight_smile:

are combined while the target in [color=green][ext-did][/color] comes from the field Set Destination on the bottom of the same screen

Both come into play in “extension.conf” lines 21++


21 [from-pstn]
22 include => from-pstn-custom ; create this context in extensions_custom.conf to include customizations
23 include => ext-findmefollow ; MODIFICATOIN (PL) for findmefollow if enabled, should be bofore ext-local
24 include => ext-did-direct ; MODIFICATOIN (PL) put before ext-did to take precedence
25 include => ext-did
26 exten => fax,1,Goto(ext-fax,in_fax,1)

The [color=blue][ext-did-direct][/color] conditions are checked during an incomming call before [color=green][ext-did][/color] has a chance. For whatever reason is [color=blue][ext-did-direct][/color] dialing to a certain (legal) extension which means I must have set it somewhere and did not unset it.

I wished I knew which field on which screen is the source for the [color=blue][ext-did-direct][/color] generation since, whatever I set in the “Add Incoming Route” screen, it never has a chance to initiate actions since [color=blue][ext-did-direct][/color] catches the did/number first and connects to that extension found there.

Please tell me how I can undo/change the unfortunate setting injected into [color=blue][ext-did-direct][/color]

(As a side note: If I manually remark out the few lines for the did in question in [color=blue][ext-did-direct][/color], everything works as expected.)

Change and unchange something on the “extensions” setup page, and then hit the red bar to re-generate. You should be fine.


You are right, that is also the screen where I screwed up!

The field …

[color=brown]Direct DID
(The direct DID that is associated with this extension. The DID should be in the same format as provided by the provider (e.g. full number, 4 digits for 10x4, etc).

Format should be: XXXXXXXXXX

Leave this field blank to disable the direct DID feature for this extension. All non-numeric characters will be stripped.)[/color]

… was the culprit. Removing its content and regenerating and the ext-did-direct entry is gone.

Thank you very much!