Problem with DialPatterns validation

Hi everyone

In outbound rules, I need fill the prepend field with “LX”, for example L1, L2… but I receive the message “Dial pattern is invalid”. Where I can add L as valid?

help please

Most trunks will have trouble dialling L, dtmf stops absolutely at D and most will stop at 9, please restrict your use to [0-9A-D].

I think you are confusing outbound routes with outbound trunks. If you are talking of dahdi lines, then you need to do that elsewhere in your outbound trunks (L(ine) is in general a G(roup) of 1 ).

Refere perhaps to

to get yourself up to speed on how asterisk works :slight_smile:

regards. . .

I need put L + one number to select a specific line in my gateway FXO… so my fxo gateway will select the line and remove LX to dial

read your gateway manual again. Then read your asterisk manual. It doesn’t work like that.

Ok, I had added this manually and worked very fine for me… exist how disable dial pattern validation?

FOX gateway manual:

FXO Port Selection
You can use the SPA9000 call routing rule to specify the SPA400 FXO ports to be
used for outgoing calls, based on the dialed digits. Use the SPA9000 Interface
page, Call Routing Rule field and Dial Plan field. The following examples illustrate
how this feature can be used.

Specifying a hunt order for FXO lines on one SPA400 unit
EXAMPLE: (<:L2{1,2}>8xx)
Line 2 is configured for a SPA400. This line is used for any dialed sequence that
starts with 8. The preference is to seize port 1. If port 1 is unavailable, the next
preference is to seize line 2. If neither port is available, then the call fails.


Then given what you wrote,just prepend 8 to the calls you send to your gateway.

(Asterisk has no real control over how your gateway works, that’s why it’s called a gateway, you will need to setup dialrules in both your asterisk boxex outbound routes and trunks (presumably) that you want to send to your gateway, and then on your gateway to suit your needs )