Problem with Company Directory on 2.1.3

I have an IVR with the company directory enabled. When a caller hits the #, the lady announces to enter the first few letters of the person’s first or last name or press 0 for the operator. Pressing 0 gets back a message that that extension number is invalid. I have tried everything I can think of to make 0 work. Does anyone know how to (a) get 0 to work in the company directory or (b) disable the dial 0 message without breaking the system?

I had the same problem. This is how I worked around it.

I created the ivr with the options I desired using the Digital Reception section of freepbx.

After I saved the ivr I went into extensions_additional.conf and copied the ivr section I had just created and pasted it into extensions_custom.conf. You can then delete the ivr in Digital Receptionist.

This is my example extensions_custom.conf file.

exten => 5000,1,Goto(ivr-2,s,1)

include => ivr-2-custom
include => ext-findmefollow
include => ext-local
include => app-directory
exten => h,1,Hangup
exten => s,1,Set(LOOPCOUNT=0)
exten => s,n,Set(__DIR-CONTEXT=default)
exten => s,n,Answer
exten => s,n,Wait(1)
exten => s,n(begin),Set(TIMEOUT(digit)=3)
exten => s,n,Set(TIMEOUT(response)=10)
exten => s,n,Background(custom/Convex_main)
exten => hang,1,Playback(vm-goodbye)
exten => hang,n,Hangup
exten => o,1,Goto(ext-local,5831,1)
exten => 0,1,Goto(ext-local,5831,1)
exten => 1,1,Goto(ext-local,${VM_PREFIX}5831,1)
exten => i,1,Playback(invalid)
exten => i,n,Goto(loop,1)
exten => t,1,Goto(loop,1)
exten => loop,1,Set(LOOPCOUNT=$[${LOOPCOUNT} + 1])
exten => loop,n,GotoIf($[${LOOPCOUNT} > 2]?hang,1)
exten => loop,n,Goto(ivr-2,s,begin)
exten => fax,1,Goto(ext-fax,in_fax,1)

; end of [ivr-2]

In my case extension 5831 is my operator/receptionist.

My only change was adding this line

exten => o,1,Goto(ext-local,5831,1)

In the above example any inbound call to the DID ending 5000 will route to the ivr.

Hope this helps and that I didn’t make any typos.