Problem with CID Number in outbound call

Hello,
i’ve a PBX with 80 extesions connect to the carrier via patton. I’ve short numbers (01879601) and any extensions can reach directly calling 0187960+ext and all works like a charm, the problem is when place and external call, the called see 0187960 as number and not real number. I’ve set the CID number for any extensions and in trunk conf the the override is unckeck.
From log I see this message:
VERBOSE[29498][C-000003f9] pbx.c: Executing [[email protected]:29] ExecIf(“SIP/800-0000070d”, “0?Set(CONNECTEDLINE(name,i)=CID:(Hidden)187960800)”) in new stack

Can be a carrier problem or my configuration error?
Thnank in advace

I’m not sure of your meaning but am guessing that you have a Patton gateway that communicates with Telecom Italia via PRI or E1 and with your PBX via SIP.

First, look at the Patton documentation to find out what SIP header should contain the outbound CID. You may have to change a setting in the gateway, if it is overriding what the PBX is sending.

Then, configure your trunk in FreePBX to put the CID into the correct header. If it’s a pjsip trunk, look at the options for Send RPID/PAI. If the CID should go in the From header, the From User field should be blank.

For a chan_sip trunk, set sendrpid in the peer details if required.

Then, look at the outgoing SIP to be sure the CID is being put into the correct header in the correct format. If it’s not, adjust your trunk settings accordingly. If the header is correct, the problem is at the Patton (or possibly with Telecom Italia). I know nothing about Patton but assume that it has some debug tools that would allow you to confirm that the proper CID is being sent to the carrier.

Thank you for reply,
yes i’ve pattojn that communicates with Telecom Italia via PRI. I’ll check into GW Conf for and override conf.

In the outbound trunk i leave the CID blank while i’ve set the CID in any SIP extensions (no pjsip).

I’ve tried to put sendrpid in trunk conf but with it set as yes i cannot hear the sounds in my IVR while if i set as yes in single extension the outbound CID remani the same.

Are you saying that when you set the sendrpid parameter in the trunk, inbound calls to your IVR stop working correctly? If not, please explain what is going wrong.

If yes, I’m stumped. AFAIK sendrpid should only affect the INVITE headers on an outgoing call. It should have no affect on incoming calls at all. You will need to provide some logs to see what is happening.

Also, please answer:
After setting sendrpid but before making any outbound calls, do inbound calls fail?
If you make an outbound call, does the correct caller ID get delivered?
If not, does Asterisk ‘sip set debug on’ show the correct caller ID header being sent to the Patton?
If yes, does the Patton’s log show the correct Calling Party Number being passed?
If yes, have you contacted Telecom Italia about this and how did they respond?
After making an outbound call, do the Asterisk logs for an incoming call show anything wrong (or is the audio just not played)?

Hello, forget problem about sendrpid it was ma error, if I set it as yes all works but without correctly cid.
Tomorrow I’ll enable the sip debug, however from log i see that frepbx set correctly callerid but sign it as hidden.
In my Patton conf there isn’t any reference to override the CID.
I’ve tried to set an CID in trunk and set it as override but the calls exit with the same, short, number.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.