Problem whith incomming calls when Softphone is down or DND (Using BUSY when an extention is ocupied)


I am using Version and I whant to have a Busy signal for incomming calls, when an extention is occupied.
This works wonderfull when I check the Disalbe option in the Follow Me Module an when the Softphone.
My Problem is: When the Softphone which usualy uses this extention is offline(coputer is powered off or something else) or in the Softphone is the DND aktivated, the caller is disconectet whith no response. I mean you get no signal or Anouncement. The pbx drop the call imidiataly.

Is there a way to change this, like a command do activate the follow me when the sip is offline, something hartcoded or an automation. Maybe a brower command when the pc is shuting down or a general setting in the pbx, to ignore the sip status when it is offline.

Sorry for my bad english that is not my native language.

best regards DRJMED

How is FollowMe configured?

Do you have a FollowMe List configured?

Do you have the Destination if no answer pointed to the user’s Voice Mail?

In current the FollowMe is configured:
Disable: Check
Initial Ring Time: 40
Ring Strategy: ringallv2
Ring Time ( max 60 sec): 30
Follow-Me List: only the extention

Annoncement: None (here is no other option available)

Confirm Calls: uncheck
Remote Announce: Default (here is no other option available)
Too-Late Announce: Default (here is no other option available)

Destinatin if no answer:
Check: Terminate Call: Play rintones to caller until they hangup

Voicemail is disabled.

Try changing the FollowMe setting under Destination if no answer to Terminate Call: Busy.

I changed the setting to Busy, but the problem is still the same.
When the Softphone is offline and I call the extention. The line is dropt immediately.

I wish do get a rintone, a forward to an other extention or something different from the pfx. But not a sudden disconect.

But when the Softphone is online and occupied, than a new incomming call should get a busy tone.

I get a busy tone. This is regardless of whether FollowMe is disable or not. And whether the IP phone is busy or the program is not started.

Tell me what versions you have.

My Extension settings that I think might matter:

Call Waiting - Disable

Voicemail & Directory - Disabled

VMX Locater - Disabled

My FollowMe settings:

Disable (not checked)

Initial Ring Time: 20
Ring Strategy: hunt
Ring Time ( max 60 sec): 10
Follow-Me List: only the extention
Announcement: None (no other option available)
Confirm Calls: uncheck
Remote Announce: Default (no other option available)
Too-Late Announce: Default (no other option available)
Destinatin if no answer:
Check: Terminate Call: Busy

So… what versions do you have?

A copy of the output of the Linux status command.

What version FollowMe?

There was a Problem inside the asterix Modul. On the dnd and offline Phones was a wrong code reversed. A colleague who understands much more than me from asterisk solved it.

But thanks for your assistance.

The PBX is installed on WMWare. Installed from ISO.
Staus screen:

Running Asterisk Version : Asterisk

  • Asterisk Source Version :
  • Zaptel Source Version :
  • Libpri Source Version : 1.4.7
  • Addons Source Version : 1.4.7

pbx.local on - eth0
CentOS release 5.2 (Final) :32 Bit Kernel: 2.6.18-92.1.6.el5


When I test your configuration with uncheck “Disable” under “Edit Follow Me” and use Check: Terminate Call: Busy
It works, but this confgiguration is not what I want to have.
When the program is not startet I get a Busy back. But when program is not stared, there should be a ring tone or a forward.

When the Progam is Stared and the extention is busy there should be Busy. That point is ok.

glad to hear it is working