Problem upgrading framework from to

Please wait while module actions are performed
Downloading framework 2403508 of 2403508 (100%)

And it just stucks over there. Going to system status there is a notice:

The following modules are disabled because they need to be upgraded:

You should go to the module admin page to fix these.

Trying to Upgrade to and Enable just stuck too.

Just tried to upgrade framework this morning and got this:

Please wait while module actions are performed
Downloading framework 2403508 of 2403508 (100%)

Fatal error: Call to undefined function: outn() in /var/www/html/admin/modules/framework/libfreepbx.install.php on line 29

Now in the module admin it shows: FreePBX Framework setup Disabled; Pending upgrade to

What do i do now? Afraid to make any changes at all at this point!

wiseoldow, I didn’t got any error but with the help of your post I googled a bit and found the answer to our problem:

Just edit /var/www/html/admin/modules/framework/libfreepbx.install.php and comment out lines 29 and 75.

I can confirm the above works. Just change these two lines:

// outn(“Checking for upgrades…”);

// out(“No upgrades found”);

(Just add the // at the start of the lines as shown)

Then you have to go into your module admin and restart the install, of course.

I am really new to the console Linux and it is hard for me some times, I have no idea how to edit this file. I have tried VI but I can not get it act right, it will open the file but I can not edit it and if I did I have no idea how to save it. and VI references are way to advanced to help a starter.
I would love to edit it using the web interface but that directory is not available. I would really appreciate some simple step by steps.

Using vi:

Place the cursor on line 29 over the “o” (of outn), press “i” (means insert) and write //
Place the cursor on line 75 over the “o” (of out) and write //
Press ESC
Write :wq and press enter

You are a life saver. also printed out for simple vi reference for later. thanks again

Thanks for the help.

I confirm that commenting out line 29 and 75 solved the error as listed on my install. 2008-02-25

Since the fix works, can’t the downloaded file be patched so that no one else runs into this?
Thanks again,

The reason that commenting out these two lines works is that that avoids the calls to outn() and out() that are failing. Looks like these functions just output text to the console, so it’s no big loss to comment them out, but it would be a more elegant solution to resolve the missing include or whatever is causing them to be undefined.

sorry guys, was stuck in in flight delays all yesterday. Should be fixed. As a future hint - you can always try the module_admin command line version which would also fix this. Or - upgrade to 2.4, that one works fine:)