Problem, unable to use system recordings *77

hi folks, im using the new beta version of freepbx along with asterisknow’s latest version 1.6. there are several issues which i am experiencing at this time.

firstly, i have a sipura2101 connected to my asterisk server. it has 2 lines which both currently have dial tones.

My problem is that i am unable to do system recordings.
i pickup the phone and hear the dial tone, then i dial * (phone becomes silent) 77 than it goes back to the dial tone. other things work such as *78 and *79. and some of the other feature codes i tried.

My other problem which might be related is that i am unable to delete my outbound route that i created. when i click delete this is what i get. maybe some bug in the beta?


You are running a Third Part module that does not support version 2.8, Route Permissions. You need to uninstall that module

Not Route Permissions, the error is coming from an older version of Custom Contexts.

You need to update Custom Contexts from the Extended repository, that will get rid of the error.

Ahh, I thought that the module name was strange, thanx for clearing that out.

so i removed custom contexts because i already had all the extended updates installed and the first issue has been solved!
however, with the other question regarding the issue that i cannot use *77. If someone has a solution it would be very much appreciated. Please let me know if i can provide more info and what.

Check that the Sipura does not use *77 internally. Do an Asterisk trace when you press *79 and then the same for *77.

im sure its not related to the sipura, because the sipura was working with my last test server from last week. no configurations have been changed on the spa other than the extention passwords.
anyways im not sure what doing an asterisk trace does or how to do it. would it be fair if i can ask you to paste me a link with this troubleshooting method and how to do it.

Open a shell to you server via ssh, type “asterisk -r”, in that cli you type “core set verbose 5” then try the *77 and watch the output. It is also saved to /var/log/asterisk/full.

I did as suggested, and i could really use some help interpreting this log.
this is the output for /var/log/asterisk/full when “core set verbose 5” is activated.

Verbosity was 3 and is now 5

so i assume i need to do “core set verbose 3” once i finish troubleshooting.

event_log has nothing outputed. completly blank.

any suggestions please. what other information can i provide please

edit. i did press *77 while verbosity was 5 and the same thing occours. i hear dial tone, i press * dial tone stops. than i dial 77 immediately after i press * and after i dial 77 the dial tone continues.

That log is not useful, do this in the cli:

core set verbose 5
logger rotate

Then dial *78 and watch the output on the screen, then do the same for *77
After that type this:

core set verbose 3

The put the log file in pastebin for me to look at

mikael thanks for the fast response,

i hope to much of the log didnt get cut out, however please take note that *77 was thelast thing i did on the phone before i did “core set verbose 3”

i noticed on line 116 it saying something about *79 so this means *77 isn’t triggering anything, not even in the logs.

thanks in advance

I have looked at the log file, and the *77 never reaches Asterisk, it must be blocked or configured at the Sipura. I suggest that you check the phone for any configuration regarding *77.

Block ANC Serv: was set to yes in my spa. changing it to no fixed the problem…

thanks alot mikael