Problem on attend transfer

Hello all…
I have a problem to transfer calls.
When I dial for an extension, and this extension answer the call but don’t want to receive that call and then hangup, the call hang up instead go to the original extension again.

I’ve tried this in a “pure” Asterisk and it works.

Can anybody help?

Thanks in advance…

It would be most helpful if you provided more information. We can’t help you if you provide no information.

What version of FreePBX? Asterisk? What brand and model of phones? Exactly how are you doing the transfer?

I just installed a FreePBX 1.812.210.57-1 distro with Asterisk and when I try “Attended Transfer”. The phones are Eyebeam and Bria. For example:

I receive a call in the 331 exten.
So I dial # (my Attended Transfer code) and the extension (332) that I want transfer to.
Then I answer the call in the 332 exten and then I hangup at this exten.
At this moment, the call should return to 331 exten, but it hangs up.

I tried in a “pure” Asterisk and it works normally.

It was a bug in the Asterisk version…
With this patch is all right.