Problem in Call Forwarding FreePBX


I need help in setting up call forwarding on my Cisco IP Phone 7942. I am Using Freepbx

Asterisk (Ver.

I have set up below config on my SEPXXXX.cnf.xml


when I press the CFwdALL button on my phone it ask for the number and after entering the destination number is plays back and say it has forwarded the number.

The problem is it automatically append “-” before the number due to which call forwarding is not working.
example = I am setting a mobile Number 123456789

after call forward is set it will play message that your call has been forwarded to -123456789.

If any one can Help ?


If you cannot resolve that, just bypass the problem. In a case that you are forwarding your call to an external problem, you can use this dial plan:

[macro-dialout-trunk-predial-hook] ;Remove spaces or dashes from outboundnumber when calling exten => s,1,Set(OUTNUM=${FILTER(0123456789*#+,${OUTNUM})}) exten => s,n,MacroExit()

put this dial plan in the extensions_custom.conf file and then type in the Linux console (not the Asterisk console) asterisk -rx'dialplan reload'.

Thank you,

Daniel Friedman
Trixton LTD.