Problem getting files from git

I am trying to install FreePBX 2.11 on Ubuntu server (14.04), using the instructions on the site (which are actually for 12.04, but so far ahve worked just fine). However, when I try

git clone http://git.freepbx.org/scm/freepbx/framework.git freepbx

It returns the following error messages:

error: RPC failed; result=52, HTTP code = 0
fatal: The remote end hung up unexpectedly

I haven’t used git before, so I am not entirely sure what it is trying to tell me.

Any help appreciated.

Thanks for your time

William.

Works fine here:

git clone http://git.freepbx.org/scm/freepbx/framework.git freepbx
Cloning into 'freepbx'...
remote: Counting objects: 32100, done.
remote: Compressing objects: 100% (8301/8301), done.
remote: Total 32100 (delta 23681), reused 31542 (delta 23301)
Receiving objects: 100% (32100/32100), 34.40 MiB | 896.00 KiB/s, done.
Resolving deltas: 100% (23681/23681), done.
Checking connectivity... done.

Alternatively you can use our mirror instead:

git clone https://github.com/FreePBX/framework.git freepbx

The mirror worked just fine. Thanks for your help.

now when I try

git checkout release/${VER_FREEPBX}

I get the error message

error: pathspec ‘release/2.11.0’ did not match any file(s) known to git

I tried

git checkout release/2.11

which returned

Branch release/2.11 set up to track remote branch release/2.11 from origin.
Switched to a new branch ‘release/2.11’

Is this what I should get? I don’t know if anything was downloaded or not.

Again, thanks for your time.

William

Look in the folder and see for yourself.

I fixed this in the wiki, thanks.