Problem Dialing from Custom Context

What the issue is:
I have a custom context which I “include” in extensions_custom.conf". The application is a kind of help line which eventually needs to Dial an outside number. I have created both an Outbound-trunk and Outbound-route. Problem is I can not dial an outside (external) number unless I include in the Dial statement the name of the outbound route.

What happened?
Dial(SIP/xxxxxxxxxx,300)will fail with the following message:

– Executing [[email protected]:4] Dial(“SIP/0201-00000043”, “SIP/xxxxxxxxxx,300”) in new stack

== Everyone is busy/congested at this time (1:0/0/1)

Dial(SIP/outbound-route-name/xxxxxxxxxx,300) will dial successfully.

XXXXXXXXXX represents the external number. If I dial this exact number form an internal extension, as opposed to the custom application, the system finds the outbound route and dials the number successfully.

What did you expect to happen?
I expected the system to find a route matching the dialing pattern and place the call without me having to specify the outbound-route name.

Can you repeat the result?
Yes, if I change the external number to dial the call still fails.
If I include the outbound-route name without changing the external number the call succeeds.

What software versions are you using?
FreePBX: 2.0.11.36
Asterisk: 11.8.1
SIP outbound trunk from Vitelity

Thanks for any help.

What did you expect to happen?
I expected the system to find a route matching the dialing pattern and place the >call without me having to specify the outbound-route name.

try

Dial(SIP/outbound-allroutes/xxxxxxxxxx,300)

outbound-allroutes

Hi, thanks for replying to my call for help.

After specifying “outbound-allroutes” in the Dial CMD, the call is not transfered to the external call and the Dial CMD timesout per the specified parameter.

Hi, just wondering, shouldn’t it be trunkname instead of outboundroute name since you’re using the DIAL app and not the goto?

Dial(local/[email protected],300)

Hi Guys,
Thanks everyone for the help. Sorry it took me a couple of days to get back but I just tried “sanjayws” suggestion: It Works!
Thanks a lot

I’m sorry is not “sanjaysws” but “lgaetz” solution that worked.
Thanks everyone non the less.