Problem configuring FXS extension

Hello, greetings to everyone because this is my first post at this forum.

I am a novice user and even took some time tinkering with FreePBX I cam’t configure an extension to FXS port.
I have a computer with the latest version of Elastix (2.0) installed and a OpenVox A400P card with three FXO ports and one FXS port. The problem, I’ve always had with previous versions of Elastix too and have never managed to solve is to operate correctly configuring the FXS port extension on my card. I have searched many forums and sites and have never found the solution.
I know this forum is only of FreePBX but like Elastix uses it in relation to the functions of PBX I decide to ask you to see if someone can help me.

When I installed Elastix A400P recognizes my card but it tells me that the four modules are unused. I check the option Replace file chan_dahdi.conf and and click button Search for new hardware and then it put the four modules in use. Then in FreePBX I create a new extension as Generic Zap Device, set the display name and Zap Channel 4, which is the channel that I have the FXS port. I click on Submit button and then at the Apply changes bar at the top.

If I connect a phone to the FXS port I have no signal, but if I call the extension, from the caller extension I hear one ring and then it pickup the call automaticly and one second later it hangs up. The FXS extension neither rings when from the caller you hear this one ring tone. It seems a problem with polarity inversions but I configured parameters like busydetect and others and I can’t make it work. Always do the same.

Anybody how what is the problem?
I’m from Spain and I have set up anywhere, neither FreePBX or Elastix. I don’t know whether to set or where.

Thank you so much.