Problem changing AMPMGRPASS

Hi all, this is my first installation of freepbx 2.9 on asterisk
I tried to do what I always did in order to change admin mgr password, but no chance to make it work
I changed admin password in manager.conf and in /etc/amportal.conf,
but it doesn’t work

The manager password was succesfully changed :
I am sure abou it, because I tried the new pass using telnet localhost 5038
Action: Login
Username: admin
Secret: MyNewPass

and the server answer was:

Response: Success
Message: Authentication accepted

Event: FullyBooted
Privilege: system,all
Status: Fully Booted

While using freepbx i see on the system status “asterisk not running” (RED)
and in the asterisk full log:

[Jul 8 14:23:21] NOTICE[16280] manager.c: failed to authenticate as ‘admin’

is there any other (new!) place where to set admin password other then /etc/amportal.conf ?

I see an occurrence of admin–> amp111 in the extensions_additional.conf, letting me really stumped;
anyway I tried to change also there with no changes

thanks in advance,

scratched /etc/amportal.conf
re run ./install_amp
entered a new password for admin manager:

at the end, looking at /etc/amportal.conf,
I can see that the password was set to amp111,
completly ignoring what I wrote…

so, surely something changed…

any help will be greatly appreciated


I post solution here in order to help anybody having same issue.

Go to advanced settings, flag display readonly settings and
also flag override readonly settings.

Now change asterisk manager password and user.

When clicking “Save”, you will have an AJAX error:

AJAX WEB ERROR: When saving key AMPMGRPASS: error
(not very fine, according to me…!)

You cannot press the orange bar (that’s ok, you changed the password…!)

Go to your Asterisk server, edit manager.conf accordingly to your new password.

Now execute amportal stop --> amportal start

Reload web page and press the apply bar: that’s all


Thank you!! That’s just crazy.