Problem After Upgrading to 2.8

Upgraded to and for the most part works really good. Before the upgrade I had Time Groups and Time Conditions screening what IVR to goto and it all worked really well. After the upgrade I have come across an issue where if I make a change to an IVR my incoming calls on my SIP trunk are no longer seen as registered, but an anonymous SIP inbound call. I have the system set to reject anonymous inbound SIP calls for security reasons. So therefore, my incoming SIP calls are being rejected by my asterisk box. I have checked the CLI and verified that ‘sip show registry’ still shows my channel registered and it does. I thought at first this was a problem with my Time Groups or Time Conditions, but removed everything to terminate all inbound routes to my extension at my desk. Still get the anonymous SIP rejections. I have shutdown astrisk and restarted it, still no change. But if I reboot the server, ‘shutdown -r now’, everything will work the way it is supposed to. Even when I add the time groups and time conditions it all will work after I reboot the server. Does anyone have an idea why my asterisk box is loosing my SIP resgistration when making a change to the IVR.