Privacy Manager problem in FreePBX

I have set privacy manager to Yes on my incoming PSTN line and it does detect correctly incoming calls that have no caller id however when it asks the person to enter their phone number, it doesn’t work. It always says the number is invalid. Eventually it will state it’s sorry you are having problems and disconnect. Is there something else I must do to activate it other than set it to yes on incoming routes?

Could you be having DTMF detection problems? How is the call arriving to your box; Sip, Iax or Zap?

Only using POTS lines so it is coming in via ZAP. Using a Sangoma card.

with POTS it should normally work, but the thing that can cause a issue is having the card configured properly for your region/telco provider.

The drivers by default (if using the digium ones) assume USA. So if you are not in the USA please make sure that you have configured it properly for your area.

I’m not sure how a Sangoma cards need to be configured for different regions but I’d start there.

Do you have a IVR? If so for calls that have a CID and get’s past the privacy manager check do they work ok with the IVR?

If you are testing this by dialing out on a SIP trunk and blocking CID to call back in be careful as it’s possible that your SIP is not configured properly to send DTMF out.

Can you dial in on the same DID and navigate an IVR. That will answer the DTMF question. Sometimes you have to play with the receive volume on TDM cards to get DTMF detection correct.

Calling in to the system with my cellphone and the callerid blocked. It does detect and go to privacy manager ok and asks to enter the phone number. But, no matter what I enter it always says its invalid and eventually hangs up. What would be a good receive volume setting to start with for a Sangoma A200d card? I am currently using 8.0 for rxgain and 4.0 for txgain.

first off, turn off privacy manager for a minute and see if when you call in and hit an IVR or voicemail if the keys work at that point as a second dtmf confirmation check. I’m guessing they will not, then slowly adjust the receive volume up. Just realize that increasing it to much can cause the same problem.

Called in to my After Hours IVR which lets the user enter an extension number and it works fine. Have tried adjusting the RX both up and down, restarting asterisk and trying again. Nothing seems to affect it. Still cannot get the privacy manager to take the entered numbers. Weird huh?

I’d call Sangoma as they have first rate support and should be able to help you determine the cause if it is card based.

Check your cell phone. On mine buried in the setup menus is a option of long bust or short burst DTMF. Short burst doesn’t work most of the time, long burst does. If I remember correctly the difference was 75 ms versus 200 ms. Maybe that is it?

If you crank up the verbose level you should see the system say if it is hearing tones and what numbers are being pressed or not. That might give you a lead also.

You can set rxgain too high also. I would start with 0 and try that. I don’t think Sangoma’s tech folks can help on this one though. If you can navigate an IVR with your cell phone, then the card is passing the DTMF correctly. There is something else wrong. I remember about a year ago there was some problem with DISA along the same lines.