Presence State in UCP doesn't work (Available allways)

The Presence states in UCP of my FreePBX 12.0.70 installation do not work.
When I as a user change the presence indicator in the upper right corner of UCP to “unavailable” or any other state, the user still receives the calls, i.e. the “available” state does not change.

Please help ASAP as this is critical for my project. Did you have any similar problem?

Thanks in advance!

The status is just that a status. If you want it to effect call flow you need to set your preferences on a per user basis in UCP under the Presence tab on the left side.

Before choosing Presence state In UCP under the Presence tab on the left side (under Home, Call History, Contacts) I set all states to “Do Not Disturb” mode except the “Available”. Nothing was changes, I receive calls from local and from queue.

Could this be the reason that my FreePBX is on KVM Virtual machine?

Please provide proper debug of a call trace. Without we are shooting in the dark

This is the part of my call debug then I call from 301 to 303 WebRTC extension then 303 state is unavailable:

– Executing [[email protected]:39] Gosub(“SIP/99301-00000004”, “sub-presencestate-display,s,1(303)”) in new stack
– Executing [[email protected]:1] Goto(“SIP/99301-00000004”, “state-unavailable,1”) in new stack
– Goto (sub-presencestate-display,state-unavailable,1)
– Executing [[email protected]:1] Set(“SIP/99301-00000004”, “PRESENCESTATE_DISPLAY=(Unavailable)”) in new stack
– Executing [[email protected]:2] Return(“SIP/99301-00000004”, “”) in new stack
– Executing [[email protected]:40] Set(“SIP/99301-00000004”, “CONNECTEDLINE(name,i)=303(Unavailable)”) in new stack
– Executing [[email protected]:41] Set(“SIP/99301-00000004”, “CONNECTEDLINE(num)=303”) in new stack
– Executing [[email protected]:42] Set(“SIP/99301-00000004”, “D_OPTIONS=TtrI”) in new stack
– Executing [[email protected]:43] Macro(“SIP/99301-00000004”, “dialout-one-predial-hook,”) in new stack
– Executing [[email protected]:1] MacroExit(“SIP/99301-00000004”, “”) in new stack
– Executing [[email protected]:44] Dial(“SIP/99301-00000004”, “SIP/99303&SIP/303,TtrI”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
[2015-07-13 09:36:02] WARNING[3113][C-00000002]: app_dial.c:2437 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
– Called SIP/99303
– Connected line update to SIP/99301-00000004 prevented.
– SIP/99303-00000005 is ringing

Presence has no effect on webrtc.

In Freepbx UCP guide is described how it works, Is this a bug?

Please provide a link to the guide.

http://wiki.freepbx.org/display/F2/Presence+-+UCP

http://wiki.freepbx.org/display/F2/Presence+State+Module

http://wiki.freepbx.org/display/F2/Presence+State+Module+User+Guide

In this documents describes how to use UCP Presence, I have same configuration, but no result, my extension available anytime.

None of the guides you posted say it works with webrtc. I stand by my previous statement.