Post-Upgrade PJSIP trunk issues

Hello everyone, new client that got bit by Flowroute’s retirement of CHAN_SIP and didn’t migrate to PJ_SIP in time. They are a small office with only a few endpoints, one ringgroup and default inbound routes on a time schedule. I have little experience doing more than extension/IVR setups for FreePBX, so I got myself a little stuck.

I noted they were on FreePBX v10-something and Asterisk 11, so to make it compatible I found a guide to help me upgrade to 13:
After this I used the GUI updater to get up to and Asterisk 13.32.0. I disabled the old trunk and created a new one following this guide:

I whitelisted all the Flowroute IPs in the GUI firewall and even ran the iptables commands listed here:

The registration now shows in Flowroute’s panel, so I know I’m most of the way there, and because the inbound route is default I should now be able to get to some nice hold music in the ring group, however when I call I get a recording that “The number you have dialed is not a working number”.

As far as logs go, I found the Asterisk logs in the webui and noted a ton of messages like this:

[2020-06-19 17:20:26] ERROR[26109] res_pjsip.c: Unable to retrieve PJSIP transport ‘’
[2020-06-19 17:21:18] ERROR[22108] res_pjsip.c: Unable to retrieve PJSIP transport ‘’
[2020-06-19 17:22:18] ERROR[26109] res_pjsip.c: Unable to retrieve PJSIP transport ‘’
[2020-06-19 17:23:18] ERROR[22108] res_pjsip.c: Unable to retrieve PJSIP transport ‘’

I’m guessing this is related but I have no idea how to interpret this and google results show other people who have encountered this have had a variety of issues with as many fixes.

Any help or direction is most appreciated!

Edit: Flowroute just sent me this log from one of their tests (scrubbed for addresses and DIDs):
2020-06-19 15:45:56 -0500 : x.x.x.x:5060 -> x.x.x.x:5060

SIP/2.0 500 Internal Server Error Via: SIP/2.0/UDP x.x.x.x;rport=5060;received=x.x.x.x;branch= z9hG4bK94ed.709f17c9e3e85a35b98253426a9a392e.0
From: “WIRELESS CALLER” <sip:[email protected];isup-oli=62>;tag= gK0e4bdc31
To: <sip:[email protected]>;tag= z9hG4bK94ed.709f17c9e3e85a35b98253426a9a392e.0 CSeq: 2056 INVITE
Server: FPBX-

Edit2: stopped the iptables service as a test with no change in symptom.

I still have to get my endpoints set up, but I fixed the above by changing the following settings:
Settings > Asterisk SIP settings > SIP Settings [CHAN_pjsip] tab > and flipping all the protocol actions to Yes.

I ran into this as well. The entry looks like its there, but it isn’t. In your PJ-SIP trunk setting, at the bottom, update the selection and restart Asterisk.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.