Post Installation problems "have no permissons on /admin"

Hi All,

I have followed the centOS5.1 installation posted on this site to the letter, the only problem that I had was zaptel (but this is beside the point).

When I try to browse my Asterisk server by typing http:// I get the main menu with ARI, FOP and FreePBX Administration.

But I can’t get any further, when I click on any of these links I get the following error “You don’t have permission to access /admin/ on this server.”

So I have done chmod 755 admin. But that still didn;t fix the problem, now I don’t get any errors but I get a totally blank page when I click on admin.

I am sure it is a permissions problem but not sure how to fix.

Your support is appreciated.

have you checked ownership of the files? /var/www/html/admin, along with all files and directories from this point on down should have asterisk:asterisk ownership.

Man…i can’t believe it. It worked. Thanks very much for your quick reply and assistance.

I may have more questions to come but at least for now it works and I also managed to upgrade all modules.


Sorry…one more generic question.

I have managed to build my box as follows:

Asterisk 1.4 (current)
Zaptel (Current)
libpri (Current)
freePBX 2.3.1

How is that different from something like PIAF1.1, Trixbox or other distributions?

Thanks again.

You have more control over your system. For example when you build asterisk you can pick and choose exactly what modules are built. It will also be easier to get support with things. If you use some bundled system like Trixbox you will find people tend to play the blame game… “Oh its Trixbox… who knows what they did to our product cause it works fine on my system where I built it from source…” etc… Then if you want to update only FreePBX but not asterisk or Zaptel then you have the power to do so and you dont have to wait around on some yum update to roll around providing the update… In short… its all about the control you gain.