Possible issue with QUEUES

Good morning, all.

I may have noticed something odd with the QUEUES module, but need to run it by some folks.

We want to make a queue that basically rings the longest-waiting agent, but if they’re on a call, the calls sit in queue for another idle agent. We also have a Join Announcement set to only play if no agents are available.

Sounds easy enough, but…

I set the queue to SKIP BUSY AGENTS, and for testing we put just 1 agent in the queue (static member). The first call goes straight to the agent (as expected - no announcement, just rings), but a second caller calls in, they hear the Join Announcement, then they get routed to the Failover Destination (in this case, voicemail). The second caller never gets placed in queue to wait for the agent to become available. We’re trying to implement Callback Queueing, but it never makes it to that step because the agent is on a call and the queue is essentially “closed” rather than waiting in queue.

On top of that, we’ve told it to speak the queue position and hold time (once). Neither happened. The Periodic Announcements were also set to use a QCB module every 1m30s, also never happened.

Skip Busy Agents: Yes
Music on Hold Class: Inherit (Agent Ringing)
Join Announcement: (When No Free Agents)
Max Wait: 3m
Max Wait: (tried both Strict and Loose)
Agent Timeout: 15s
Retry: None (also tried 15s and 60s) - see note below about the oddities on this setting
Auto Pause: No (also tried Yes)
Auto Pause on Busy: No (also tried Yes)
Auto Pause on Unavailable: No (also tried Yes)
Max Callers: 0 (also tried 2)
Join Empty: Yes
Leave Empty: No
Announcement Frequency: 15s (for testing)
Min Announcement Interval: 30s (for testing)
Announce Position: Yes
Announce Hold Time: Once
Breakout Type: Queue Callback
Queue Callback Module: QCB-Test
Repeat Frequency: 1m30s

Here’s the really odd part about RETRY - when retry is set, the music on hold resets at that time, almost as if the call as left and re-entered the queue completely.

Thoughts? I’m perplexed…


You’ve been here long enough to know we can’t see what’s actually happening without logs. Post the log of a call and let’s see why the call is falling out of the queue.

I’ll run a call and capture, but I was thinking someone may see that I’ve got an option not set right that might be doing that. No reason to be nasty.

And actually, a reboot we did this weekend, corrected it. LOL

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.