Polycom Trio 8500 sip registration issue

I have a Polcom 8500 conference phone, i can’t get it to register a line with the FreePBX.
The phone has software installed and I have Asterisk 11.21.2 installed on my PBX. Basically i can’t get the phone to register a sip line. I get the following error in the console window:-

[2019-05-27 15:26:46] WARNING[1877]: chan_sip.c:16562 check_auth: username mismatch, have <107>, digest has <>
[2019-05-27 15:26:46] NOTICE[1877]: chan_sip.c:28360 handle_request_register: Registration from ‘sip:[email protected]’ failed for ‘’ - Username/auth name mismatch

I have tried putting a .cfg file in the boot area, but i don’t know how to check if the phone is using it, basically i am one step away from giving up with this. Why is it so difficult??

Screenshot the line configuration because it looks like either a setting is missing or in the wrong spot. The phone isn’t sending proper auth details.

If you can get to the web interface on the 8500, make sure that for the SIP Line Identification, you have both Address and Authentication User ID set to 107, and that Authentication Password matches what you have for extension 107’s Secret in FreePBX.

If you must use .cfg files, set a Label in the file and confirm that it appears on the phone.

1 Like

So i have uploaded the sip line settings, I would prefer not to have a cfg file but i can’t get it to work so i was trying anything. Its not loading my cfg file anyway.
i have to set the following in the sip line identification:-

Uhm and you have everything setup on the server for TLS? Why is the phone using the TLS transport but not configured fully for TLS?

I set the password for the extension in the admin -> User manager for this extension

Not sure why its using TLS not even sure what that is?

Change the Transport on the phone to be UDP.

phone logs:- 0527152019|mrlib||00|Initial log entry. Current logging level 4
0527152040|copy |4|00|Configuration of URL failed
0527152040|clist|4|00|dbIO::processResult:no host
0527152643|cfg |5|00|Prm|Parameter acd.reg requested type 0 (UInt) but is of type 2 (SInt)
0527152643|usbpp|4|00|[PpsUsbC]: OnEvReg Accepted
0527152643|sip |
|00|Sip Unregistering user:107 display name:107 authorizing user name:‘107’ index value:0
0527152643|sip |4|00|SipRemoveMonitoredUser : CSTA Line Not Found
0527152643|sip ||00|SipUserRemove: user 0 being removed.
0527152644|cfg |5|00|Prm|Parameter acd.reg requested type 0 (UInt) but is of type 2 (SInt)
0527152644|cfg |5|00|Prm|Parameter reg.x.outboundProxy.port requested type 0 but is of type 2
0527152644|sip |
|00|Sip registering user:107 display name:107 authorizing user name:‘Using Login Cred’ index value:0
0527152644|utilm|4|00|uBLFUnCompressed: File /data/polycom/ffs0/Config/Local/WebTicket/0/sip.usr doesn’t exist or is empty
0527152648|sip |*|00|User removed
0527152651|copy |4|00|Configuration of URL failed
0527152651|cfg |4|00|Prov|Could not download file 64167f1dac58-web.cfg
0527152651|cfg |4|00|Prov|Uploading phoneWeb.cfg failed
0527152651|cfg |4|00|Prov|Update configuration failed

I have a local PBX does that change things? So i am expecting the phone to connect to the local PBX and not a hosted PBX. if that makes sense.

Solved my issue, i didn’t realise that I needed to use the ‘Secret’ password as part of the authentication. Every day is a school day.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.