Polycom Soundpoint IP 650 has wrong time


#1

Hello all,

I have one Polycom Soundpoint IP 650 who’s time is an hour behind. I am using OSS endpoint manager and all other phones are showing the correct time. The server has the correct time as well. I am working remotely on this but the local team sent pics of the config. The non working phone’s ntp server was set to 0.pool.ntp.org and the working phone’s ntp server was the address of the pbx. I logged into the phone directly and changed the ntp server to match the working phone and it still had wrong time after a reboot. The odd thing is, the ntp server in global settings of endpoint manager was set to 0.pool.ntp.org, but the dhcpd.conf had the pbx address. I changed global settings in endpoint manager to the address that the working phone had which is the address that is also in dhcpd.conf, so I guess that is what that phone actually grabbed. I have deleted the non working phone from the endpoint manager and re-added it while factory resetting the phone. We are using ftp provisioning and dhcp option 66. The phone still comes up with the wrong time. Can anyone guide me on where to look further to troubleshoot this, or have any insight on how to fix this? Is this possibly OSS endpoint manager’s problem?


#2

So it has the correct UTC time from NTP, but there are settings in the polycom config files that control the offset from UTC shown on the Polycom.
tcpIpApp.sntp.gmtOffset
tcpIpApp.sntp.gmtOffset.overrideDHCP << depends on whether or not you want the offset to come from DHCP

the ones below control when daylight Savings is turned on

tcpIpApp.sntp.daylightSavings.enable
tcpIpApp.sntp.daylightSavings.start.month=“3”
tcpIpApp.sntp.daylightSavings.start.date=“8”
tcpIpApp.sntp.daylightSavings.start.time=“2”
tcpIpApp.sntp.daylightSavings.start.dayOfWeek=“1”
tcpIpApp.sntp.daylightSavings.start.dayOfWeek.lastInMonth=“0”
tcpIpApp.sntp.daylightSavings.stop.month=“11”
tcpIpApp.sntp.daylightSavings.stop.date=“1”
tcpIpApp.sntp.daylightSavings.stop.time=“2”
tcpIpApp.sntp.daylightSavings.stop.dayOfWeek=“1”
tcpIpApp.sntp.daylightSavings.stop.dayOfWeek.lastInMonth=“0”