Polycom IP6000 Incoming Call Problem

Have a system at a client site running FreePBX Distro 6.12.65-24 no real issues since it was installed 4 months ago.

They have a Polycom IP6000 conference phone in the boardroom, can make outgoing calls with no issue whatsoever. Well last week someone tried to do something different… call in to the boardroom. The phone rings, the leds flash so you try to push the offhook key (or the answer softkey)… the phone stops audibly ringing but the leds keep flashing and the caller continues to hear ringing from their end. The phone is not locked up, as pressing the reject softkey will terminate the call but no matter what I do I can’t get the thing to answer. Doesn’t make any difference if the call is dialed directly to the phone, or if the call is transferred… same result.

I’ve never seen anything remotely like this, so I don’t know if I should be looking in the phone’s configuration, the freepbx configuration, whether I should be switching the extension to SIP instead of PJSIP.???

Any ideas are greatly appreciated.