Polycom IP501 Phone Picked up but Still Ringing

Although I have successfully used Polycom phones with Asterisk/FreePBX for a number of years, I have a problem with an installation of one in a remote (home office) location. The issue is that the phone rings, I answer and the caller can still hear ringing.

I found this entry on the Voip Info Polycom entry (http://www.voip-info.org/wiki/view/Polycom+Phones):

For more information about why Polycom phones don’t seem to like type=friend, and to explore a fix for a known Polycom bug, the “One Way Communication” issue, where you can hear a person talking, but the Polycom, although connected, still has a ringing tone, please visit:
http://www.southwestfcu.org/tech/polycomsip.html

which may apply but has a broken link so I can’t find the information elsewhere.

Since this possibly could be a problem seen before, I’m hoping someone else has solved it already.

I can provide detailed logs if necessary, but here is my basic configuration information:

  • FreePBX Framework (2.5.2.2), Core 5.5.2.1 (all up to date)
  • Asterisk 1.4.22
  • hosted at LYLIX (no NAT)
  • Home network behind DLINK DIR-655 Router

and sip.conf as follows:

[22317]
deny=0=50.0.0.0/0.0.0.0
type=friend
secret=271828
qualify=yes
port=5060
pickupgroup=
permit=0.0.0.0/0.0.0.0
nat=no
[email protected]
host=dynamic
dtmfmode=rfc2833
dial=SIP/22317
context=from-internal
canreinvite=no
callgroup=
callerid=RH Polycom <22317>
accountcode=
call-limit=50

Try nat=yes

Thanks for the suggestion, but to be clear, the phone system isn’t behind a NATted firewall (it used to be, but isn’t now). Also, I have a phone attached via a Sipura ATA at the same location as the Polycom, that works great with “nat=no”.

So, there is some much more subtle thing that causes the phone to still continue ringing after being answered.

There are some specific troubleshooting steps I run through when experiencing this issue.

Subnet C = client’s home where the phone is located
Subnet O = corporate Office where the FreePBX server is located

If you can then…

1 - Put the phone inside “subnet O” where the FreePBX server is located. If the problem persists but other phones on the same subnet are working properly then try upgrading the firmware in the phone. If that does not resolve the problem then login to the phone’s web interface and swap the SIP configuration with another functional phone (while unplugging that phone). If the problem persists then it is probably a malfunctioning phone and it should be replaced.

If more than one phone sharing the same subnet as the PBX is exhibiting the same symptoms then it could be a server configuration problem or a switch problem.

2 - If you confirmed the Polycom works fine sharing the same subnet as the FreePBX server then take the phone back to Subnet C. Plug it back in. Reconfigure the proxy IP address to point to the IP address of the FreePBX public facing router. If problems persist then you know it is not the phone but a connectivity issue.

3 - Setup a temporary FreePBX server on Subnet C. Try calling from extension to extension on the local subnet. If the problem is not reproducable then it is an issue with your internet connection.

4 - Check the following for potential issues:

  • Confirm sip_nat.conf is configured properly on the PBX. If you are using a hostname instead of “externip” then SSH into your PBX and use NSLOOKUP to confirm your hostname resolves to your correct external IP. The resolution should not take more than a couple hundred ms.
  • Forward UDP 8766-35000 and UDP 5060-5080 on Subnet O’s perimeter router. You can shrink these ranges once you have finished troubleshooting.
  • Confirm the firewall is disabled or severely limited on the Subnet O perimeter network.
  • Use traceroute and ping to confirm there is a point-to-point path available between the home agent and the PBX.
  • Confirm the home agent’s router is using the least restrictive firewall configuration possible. In some routers you need to disable “secure firewall” or disable “SPI or Stateful Packet Inspection”.
  • If problems persist then consider swapping the router with a Netgear WGR614.

There are a number of other possible causes including problems with the either the home agent’s ISP, the corporate office’s ISP, a cabling issue, etc…etc…