Polycom Hybrid Registration?

Has anyone played with the newer released Hybrid Registration features within Polycom VVX series 5.8+ software? Line 1 registers as Skype for Business perfectly however Line 2+ are supposed to be able to register to a generic SIP account. I have a VVX601 here that when configured doesn’t send anything at all to my local FreePBX configuration. Packet captures and all show absolutely nothing. Figured it couldn’t hurt to see if anyone here has played with them.

I know on our Trio 8800 it doesn’t dual-register.

It’d be nice if it did… but I don’t know if it even supports it.

It actually has for a bit now going back to 5.4.5 for the Trio’s supposedly.



I spoke with Polycom the other week too to confirm this and they claim it does work as well. Whether anyone outside of Polycom has gotten it to work though is the question :slight_smile:

1 Like

I got it to work! Played with it Friday afternoon, it is now registering on both Skype for Business and on our PBX as two separate lines.

How? You shouldn’t tease the animas - it makes they cranky. :smile:

LOL… OK… here are the steps.

  1. update your firmware (of course).
  2. Set the system for “Skype for Business” as normal.
  3. Import the attached configuration, which gives you multiple line abilities
  4. Now, if you go to Settings --> Lines and look on the left, you will see that you have 3 lines instead of 1.
  5. Switch to Line2, and put in your registration information for Asterisk.

Voila! Now your phone will show two lines, line 1 being Skype for Business, and line 2 being your PBX. Just tap the line before you dial.

(Hmmm… it won’t let me upload a .cfg file… so here it is… just save it as TrioMultipleLines.cfg and import it…)

<?xml version="1.0" standalone="yes"?>
<!-- Enable multiple Registrations on a RealPresence Trio -->
<!-- number min 1 max 3 -->
<!-- You cannot simultaneously register two Skype for Business lines -->
<!-- Line 1 always has to be Skype for Business -->
<!-- lync.provisionDeviceParams.enabled This parameter is required only when line 1 is -->
<!-- Skype for Business line -->
<hybrid 	reg.limit="3" 

Yea I’ve tried that and just retried it as thats included in the settings that I pushed. Unfortunately the phone doesn’t send anything to the FreePBX server showing by tcpdump. Glad to see it worked for someone though!

So I am not sure what we did but I worked with a colleague at Polycom. After a hard reset and a few things he changed it is working. I’d assume the hard reset fixed things I may have changed inadvertently that were causing issues but no idea. Moral of the story - hard reset the phones when you see funky behavior like that.

It’s working fine through our PBX… however… it’s not making Skype for Business calls now. I don’t see a setting anywhere that says “Use line x as default for outbound calls” either.

Of course, it has been in use now for 3 days straight, so I haven’t had time to play with it again.

Yea I was told Skype hijacks the digitmaps which is expected and I haven’t had a moment to play with that. To pick the outgling Line for use I just pick that one on the phone then dial, vs just dialing at the moment.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.