Polycom error; provisioning error: failed to update configuration

I am running FreePBX 2.9.0.12. I cannot get my polycom soundpoint 6000 to provision properly.

I have done the following:

  1. Connected my phone to the network, changed it to the proper network and tftp boot settings.
  2. Went into End Point Device list (under End Point Manager) search my network and it finds the phone I connected with an IP. I set the line and extension desired and press the “Add” button. After pressing the button my browser loads a white page and does not reload properly unless I reload the webpage.
  3. I reload the page and see that it has all the correct information under my End Point Device list.
  4. Afterward I reboot the phone, and get the following error
    Provisioning Error: Failed to update configuration.

I have attempted to login to the phones web-interface and entered in the settings manually, then tried to restart the phone again but got the same error.

Any suggestions on what may need to be done or change would be much appreciated!