Plz help me with hylafax/ iaxmodem config!

hi all ,
i follwed this wiki to configure hylafax @ freepbx

http://www.webhostingchat.com/forum/articles-howtos/26618-hylafax-server-install-connection-elastix.html

i did all in the wiki , but uptill now cant send fax…
i changed default the iax fax port to 5012 .

i have mode the iax extention

peername 700
secret 544657465

both of hylafax & iaxmodem is working
[[email protected] ~]# /etc/init.d/hylafax status
HylaFAX client-server protocol server: hfaxd (pid 11203) is running…
HylaFAX queue manager process: faxq (pid 11200) is running…
[[email protected] ~]# /etc/init.d/iaxmodem status
iaxmodem (pid 11502) is running…

[[email protected] ~]# cat /etc/iaxmodem/
config.ttyIAX iaxmodem-cfg.ttyIAX1 ttyIAX1.
[[email protected] ~]# cat /etc/iaxmodem/iaxmodem-cfg.ttyIAX1
device /dev/ttyIAX1
owner uucp:uucp
mode 660
port 4569
refresh 300
server 127.0.0.1:5012
peername 700
secret 544657465
cidname John Doe
cidnumber 54405551212
codec slinear

here is my log files :
[[email protected] ~]# ^C
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem
iaxmodem iaxmodem-cfg.ttyIAX1
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem
iaxmodem iaxmodem-cfg.ttyIAX1
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem
[2014-05-08 02:48:56] iaxmodem process 30517 ended, status 0xF
[2014-05-08 02:50:26] Modem started
[2014-05-08 14:41:38] Terminating…
[2014-05-08 14:41:38] iaxmodem process 1850 ended, status 0xF
[2014-05-08 14:41:38] Modem started
[2014-05-08 14:55:13] Terminating…
[2014-05-08 14:55:13] iaxmodem process 11117 ended, status 0xF
[2014-05-08 14:55:14] Modem started
[2014-05-08 14:57:15] Modem started
[2014-05-08 14:59:57] Modem started

^C
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem
iaxmodem iaxmodem-cfg.ttyIAX1
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem
iaxmodem iaxmodem-cfg.ttyIAX1
[[email protected] ~]# tailf /var/log/iaxmodem/iaxmodem-cfg.ttyIAX1
[2014-05-08 15:00:09] Registration failed.
[2014-05-08 15:02:10] Registration failed.
[2014-05-08 15:04:52] Registration failed.
[2014-05-08 15:05:04] Registration failed.
[2014-05-08 15:07:05] Registration failed.
[2014-05-08 15:09:47] Registration failed.
[2014-05-08 15:09:59] Registration failed.
[2014-05-08 15:12:00] Registration failed.
[2014-05-08 15:14:42] Registration failed.
[2014-05-08 15:14:54] Registration failed.

================

now from software called "yajfax "
i can conect to the server with user 5001 and pwd with password5001 but cant send fax.

when i upload fax and send , it say "waiting " state …

also , i dont see any logs in
/var/log/asterisk/full
when i send faxes by the client ??!!!

any help ?

regards

nothing to do with freepbx its all how you set up hylafax and iaxmodem. go there for support, (it works very well when you do it right)

You might want to note a setting called requirecalltoken=no, and whether it is turned off in freepbx or not.