Please, please HELP!: Recordings not working

I can not record any message from my extension using *77. After dialing *77 as soon as I get the beep it gets disconnected. I think it is a format problem because I get this:

[Nov 11 11:57:10] VERBOSE[6250] file.c: – <SIP/101-0000001a> Playing ‘beep.g729’ (language ‘es’)
[Nov 11 11:57:11] WARNING[6250] channel.c: Unable to find a codec translation path from 0x100 (g729) to 0x40 (slin)
[Nov 11 11:57:11] ERROR[6250] channel.c: Could not set write format to SLINEAR
[Nov 11 11:57:11] WARNING[6250] translate.c: No translator path from alaw to unknown
[Nov 11 11:57:11] WARNING[6250] file.c: Unable to translate to format wav, source format g729
[Nov 11 11:57:11] WARNING[6250] app_record.c: Problem writing frame
[Nov 11 11:57:11] VERBOSE[6250] app_macro.c: == Spawn extension (macro-systemrecording, dorecord, 3) exited non-zero on ‘SIP/101-0000001a’ in macro ‘systemrecording’
[Nov 11 11:57:11] VERBOSE[6250] pbx.c: == Spawn extension (from-internal, *77, 3) exited non-zero on ‘SIP/101-0000001a’
[Nov 11 11:57:11] VERBOSE[6250] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/101-0000001a”, “”) in new stack
[Nov 11 11:57:11] VERBOSE[6250] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/101-0000001a’
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: – Timeout on SIP/GXW_trunk-00000019, going to ‘t’
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: – Executing [[email protected]:1] Set(“SIP/GXW_trunk-00000019”, “TIMEOUT_LOOPCOUNT=1”) in new stack
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: – Executing [[email protected]:2] GotoIf(“SIP/GXW_trunk-00000019”, “0?final”) in new stack
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: – Executing [[email protected]:3] Playback(“SIP/GXW_trunk-00000019”, “”) in new stack
[Nov 11 11:57:12] WARNING[6243] app_playback.c: Playback requires an argument (filename)
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: == Spawn extension (ivr-5, t, 3) exited non-zero on ‘SIP/GXW_trunk-00000019’
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/GXW_trunk-00000019”, “”) in new stack
[Nov 11 11:57:12] VERBOSE[6243] pbx.c: == Spawn extension (ivr-5, h, 1) exited non-zero on ‘SIP/GXW_trunk-00000019’

The audio codec I am using is G729 to avoid network problems. Any help???

In General Settings, see if the Call Recording Format is set to g729.
If so, try WAV.

In General Setting I tried both formats, G729 and WAV.