Please help Cannot receive incoming calls

Hi I installed a new system using a VM. I did a simple configuration with 1 extension.
I can make outbound calls no problem, means I successfully registered with my voip provider.
I am not able to receive any incoming calls. I am monitoring the asterisk log files and I see no activities when I try to make a call from my cell to the number.
However, when I do I “tcpdump -i any port 4569” I do see activities and traffic coming in. Means I have the ports correctly forwarded from my firewall.
Where can Iook from here? Please help…

Thank you.

That isn’t necessarily true. Inbound and outbound calling are not the same thing.

If you can make outbound calls, your outbound connection is getting authenticated, but your inbound requires registration, which may or may not be getting set up correctly. Check your /var/log/asterisk/full log to see what error the registration attempt is reporting.

registration is fine. I confirmed with my provider.
Asterisk full log shows registration succesful.

I did a netstat:

[[email protected] ~]# netstat -nap | grep asterisk
tcp 0 0 0.0.0.0:5038 0.0.0.0:* LISTEN 1551/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:40020 ESTABLISHED 1551/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:40016 ESTABLISHED 1551/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:40026 ESTABLISHED 1551/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:40014 ESTABLISHED 1551/asterisk
tcp 0 0 127.0.0.1:5038 127.0.0.1:40006 ESTABLISHED 1551/asterisk
tcp 0 0 :::8088 :::* LISTEN 1551/asterisk
tcp 0 0 :::8089 :::* LISTEN 1551/asterisk
udp 0 0 0.0.0.0:55674 0.0.0.0:* 1551/asterisk
udp 0 0 0.0.0.0:5160 0.0.0.0:* 1551/asterisk
udp 0 0 0.0.0.0:5060 0.0.0.0:* 1551/asterisk
udp 0 0 0.0.0.0:4569 0.0.0.0:* 1551/asterisk
udp 0 0 :::56394 :::* 1551/asterisk
unix 2 [ ACC ] STREAM LISTENING 14333 1963/node /var/lib/asterisk/ucp/sock/worker.1496338091061gEJ.sock
unix 2 [ ACC ] STREAM LISTENING 13009 1551/asterisk /var/run/asterisk/asterisk.ctl
unix 2 [ ACC ] STREAM LISTENING 13628 1758/node /var/lib/asterisk/restapps/sock/worker.1496338087657Zb2.sock
unix 3 [ ] STREAM CONNECTED 13017 1551/asterisk

Am I supposed to see a “TCP listen 4569” entry? I don’t see that, Does it mean Asterisk is not “listening” to 4569?
I only see a udp entry.

You know what you need to do. Drop off the firewall and test it.

OH boy… Finally figured it out…
Trunk name MUST be the same as what my provider told me. I don’t understand why that matters.
FYI, its voip.ms and the trunk name MUST be set to “voipms”
:rage: