Play Recordings fail with "sent to invalid extension but no invalid handler"

When creating a destination to “Play Recording”, calls fail with the following error:

– Executing [[email protected]:11] Goto(“SIP/flightproae-00000068”, “play-system-recording,14,1”) in new stack
– Goto (play-system-recording,14,1)
[2016-12-17 17:46:28] WARNING[61258][C-0000003e]: pbx.c:6863 __ast_pbx_run: Channel ‘SIP/flightproae-00000068’ sent to invalid extension but no invalid handler: context,exten,priority=play-system-recording,14,1

I have tried this on two separate FreePBX 13 systems (one of which is a brand new Distro) with the same result. My recordings are all .wav format and they play properly if attached to an IVR. It seems to be a bug in the Play Recording destination. The behaviour is the same even if I create a Misc Application and set the destination to Play Recording. All recordings fail.

I have tried fwconsole chown. No difference.

The currently loaded Recordings module is 13.0.30.5 in both PBXs.

Any ideas?

Regards,

Andy

This was already fixed in 13.0.30.3

Hi Andrew,

As I mentioned above, I am using 13.0.30.5…

Maybe the fix didn’t carry forward?

Regards

Andy

Just checked that the dialplan exists. You can search for it in /etc/asterisk/extensions_additional.conf

I have a dialplan called “outbound-allroutes” and another called “flightproae” in /etc/asterisk/extensions_additional.conf.

There is a line: “exten => 100,n,Goto(play-system-recording,14,1)” however I do not see an actual dialplan called “play-system-recording” in this same file, so maybe this is what it means by “invalid extension”.

Hi,

It’s a long shot… and seems to have nothing to do with it…

but i just resolved an issue i had on a clean installation of Freepbx where internal calls (between extensions) had failed - and i received the same error (“sent to invalid extension but no invalid handler: context,exten: bla bla bla”)

It turns out that during my configuration - somehow the find me/follow me for the extension switched to yes , with a ring time of 0 seconds. where the destination is the extensions itself (happened after bulk extension update using the new bulk handler).

Check and see if by mistake - it is marked on your extension/destination as well…

Jonathan

If you have the newest version and don’t have the dialplan then there is a deeper issue going on that we will be unable to resolve unless you go through commercial support. For liability reasons we can’t login to other machines without a support contract.

As I mentioned, the issue is on two PBX machines which are at the same version. One of these machines was recently (ie within the last month) installed directly from the Distro. The other has been around for a while. Both machines are activated with some commercial modules installed.

If I use commercial support, will there be a cost for this? Maybe an alternative might be to raise a bug report and see if the issue can be replicated?

Thanks for the suggestion John,

My situation is rather different. I have an outbound route that catches numbers like Directory Enquiries and Operator Services in the UK (100, 118X. etc). The destination for this route is simply “Play Recording” with a .wav file that states: “Calls to this number are barred.” after which the route will hangup.

That being said, I have created a custom application which also points to “Play Recording”, with the same result.

Given that no dialplan exists for “play-system-recording” which is called directly, this would account for the error. My understanding is that this system dial plan should be generated by the FreePBX Recordings Module and for some reason it isn’t.

[Edit] Word exchange error: delete “system-play-recording” substitute “play-system-recording”.

As far as I am aware, that doesn’t exist anywhere. ‘play-system-recording’ is part of the Commercial ‘broadcast’ module.

:confused: This is what is being called by the “Play Recording” destination, which is not a commercial module.

‘Play Recording’ is, most certainly, part of Broadcast.

If that module has stopped working, it may because your machine has lost its activation? You may need to re-activate it.

If you’re seeing that as an option and you don’t have Broadcast, then there’s a deeper problem here 8-</strike>

Edit: Whoops, it’s ALSO part of ‘recordings’, ignore me. I’m investigating.

Edit 2: Yes, this seems like a bug. I can see that “play-system-recording” is exposed as a destination in recordings, but I can’t see where the dialplan that actually GENERATES that function is. (I didn’t look hard, however).

We have our weekly bug triage tomorrow morning my time (about 15 hours from when I posted this message), so if you can create a ticket about this, it’ll get looked at tomorrow.

Please don’t create a ticket on this. One already exists and was passed by QA. We will need to look into that. Creating a other issue only convolutes the system. Thank you.

Roger. I’ll leave it alone.

Thanks

Andy

Cheers Rob,

I thought I was going mad as I don’t have (and never have had) a ‘Broadcast’ module.

Thanks for looking into this.

Andy

I finally understand the issue. The issue is that broadcast (the commercial module) is the only thing that provides this context.

2 Likes

Hi Rob / Andrew,

Just to manage expectations, did your triage meeting suggest any timescale or resolution for the issue of the missing “play-system-recording” context?

Regards

Andy

This is already resolved in Recordings 13.0.30.6

Thanks Andrew,

My Module Admin doesn’t show this version as being available yet…

It’s in edge. Unless you are in edge mode you won’t see it.