Pjsip with Flowroute

Everytime I flip the driver in Advanced Settings from both to just pjsip, and then run fwconsole restart I can no longer do incoming/outgoing calls.

Incoming gets a few rings, followed by a “number disconnected” type message
Outgoing gets “all circuits busy”

Turning chan_sip back on and restarting again solves it. I’d really like to move to just pjsip. Ideas?

I have tried this with the FreePBX firewall disabled too.

The two drivers run on different ports. one uses 5060 and the other uses (depending on your configuration) either 5160 or 5061. Turning off the channel driver, in and of itself, doesn’t change any of the port assignments.

I’m going to guess that your system is using 5060 for ChanSIP and when you turn it off, everything that’s communicating with your system on 5060 goes dark.

Also it doesn’t sound like you are migrating your trunk settings to pjsip. Maybe you are expecting it to just change to pjsip from Chan sip but that is not how it works.

What’s entailed in doing this? Current trunk settings:

allow=ulaw&g729 ;uncomment this line if you have G.729 licenses installed.