PJSIP trunk without username, neither password, nor registration


This is the first time I have to configure a PJSIP trunk ithout registration. All the information I got from the provider, is de IP of the outbound proxy, and the DID.

I have configure it in this simple way, but I allways get this error, and can’t get it working:

“Could not create dialog to invalid URI ‘Provider_Name’. Is endpoint registered and reachable?”

This is the configuration I use:

Rest of the values are configured with deffault values:

I allways use username and password for registration, and I have no experience with this kind o trunks.

All trafic from the provider, 5060UDP port and 10000-20000 UDP ports are forwarded to the PBX.

any help please?


In your configuration what have you set on host item?
Should be set your provider with the IP address or domain name supplied by your ITSP.

In Advanced set ,
“Outbound Proxy” to sip:’hostname’
And from domain as “your IP”

Them check pjsip show endpoints you should see ‘available’ and ‘Matches’ should have your ITSP ip address

The answer probably lies under the red splodge. Unless this is an IP address or fully qualified domain name, it is wrong.

1 Like

Well, under the red splodge there is the provider IP address. This is the sip server on the provider side.

Will try on monday other options and will post feedback. Thank you all!

Hi dazzagrant,

I did the changes, and set “outbound proxy” to “sip:X.X.X.X” (X.X.X.X is my provider’s server IP), and “from domain” as “my public IP”.

This is qhat I get on "pjsip show endpoints’:

Endpoint: MY_PROVIDER Unavailable 0 of inf
Contact: MY_PROVIDER/sip:X.X.X.X:5060 115cdbed7d Unavail nan
Transport: udp 3 96
Match: X.X.X.X/32

It doesn’t seem to be working… any idea?

Thank you!

Hi david55, it is my provider’s public IP.


Which one is de the host item on the menu? What do you meean?


Check your providers IP, are certain it’s an IP as FQDN would be better
Also check you can ping your providers IP

ping works ok. There is no FQDN, only IP.


Your next step because it authorised via IP you will need to check with the provider that have the correct IP

Before contacting them from ssh shell check you have gave them the correct IP by using
fwconsole extip

The item which david55 have referred as: “under the red splodge”

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.