PJSIP Trunk with Auth Username/AuthID

I have two SIP service providers, CallCentric and RingCentral.

My CallCentric account has two DIDs, and I am able to set those up just fine.

My RingCentral account has a single DID, but it has a username and an AuthID (that’s what they call it).

I cannot get FreePBX or Asterisk 16 to connect. I am getting a 401 temporal response/unauthorized response when trying to register. I think it has to do with the AuthID not being sent properly, and with me being a new user of PJSIP. I spent hours last night googling, but I didn’t come up with anything related to AuthID other than it may be considered Auth Username now.

I am coming from Asterisk 11.6, and I was able to force the registration using the register => formatting. However, I’m having issues with CallerID being passed in on all of my trunks, probably because of how I’m reformatting all of my contexts and the like. Anyway, that’s why I wanted to upgrade.

So, examples of logins/registration settings:

1777123456789100 -> Maps to DID 1 via call routes
Username: 1777123456789100
Password: somepass

1777123457789101 -> Maps to DID 2 via call routes
Username: 1777123456789101
Password: somepass2

Sets up, runs fine.

12345678901 -> DID
Username: 12345678901
AuthID: 999888777666
Password: somepass
Outbound proxy: SIP10 (dot) ringcentral (dot) com:5090

401 temporal response. SIP shows unauthorized. PJSIP list registration shows Rejected.

I have named the trunk the AuthID, Username is the DID.

I think I am either not getting the outbound proxy to work, or the AuthID isn’t sending, or both. I am not sure what to do or how to troubleshoot. Any and all help is appreciated.


I had to really hack this solution. Here’s how it currently works:

In PJSIP general settings for the trunk, the username is the authID.

The secret is the user password.

In PJSIP advanced settings, the From User is the username.

The client URI needs to be sip:[email protected]

The Outbound proxy can be set if needed.

Here in case anyone else has the same issue.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.