PJSIP Trunk, Flowroute POP, Chan_Sip Phones. Best Practice?


(Caribbean Voip) #1

Good Morning,
I’ve stepped in it and need some help.

FreePBX 14.0.13.12
Asterisk 15.7.3
Flowroute DID
Linux version 3.10.0-957.21.3.el7.x86_64

Our system was working fine until about 2 months ago it stopped registering with Flowroute. Looked like the issue was we were still using a chan_Sip trunk. So, I created a new PJSIP Trunk (using 5160) and followed the guide from Flowroute. (Our phones listen on 5060)


Registration fixed and all things worked fine. (Sip Registration with Flowroute)
Yesterday, we started getting calls dropped. Registration was failing/reconnecting over and over. I followed another guide to switch over to IP registration with flowroute.

(Nice, well done guide btw) I made all the changes in FreePBX and Flowroute.
However, this did not solve the registration problem. I felt this was b/c I was using 5060 for my sip phones and 5160 for the pjsip Trunk. So, I tried to swap those. I didn’t find a ‘How To’ for that so I winged it. Fail. Mistake. Lost connection to 50 phones. Time to punt. Did a restore from 2 days ago. Ran some important system and module updates. Network power-cycled the phones and now I am back to where I was. Internal communication is fine but no Flowroute registration so no calls going in/out. Understandable b/c I have not (and don’t want to) go back to Flowroute Sip Registration. Thanks for following me this far.
So, my question is: Is my problem that my pjsip trunk is using 5160 and my phones are on chan sip with 5060? How Should This be setup for the long term? System is broken now so I might as well fix it right. Is there a guide for changing my sip phones on 5060 to pjsip phones and should I do that? I’d bet there are guides but I’m not finding them. Let me know if I did not describe necessary details about my predicament.
I would appreciate any guidance, suggestions, useful links you can provide.
Thanks in advance.


#2

If you use IP routing , you should not also be trying to ‘register’.


(Caribbean Voip) #3

Understood. That’s incorrect terminology on my part. I switched to IP Authentication. That’s why I was not seeing Registration attempt messages in Asterisk.