Pjsip trunk & did incoming number setup


(Roger Östergren) #1

I have successfully setup my SIP trunk provider Cellip with Freepbx 12.0.19, my only issue is that I don’t know how to route DID into Inbound Routes. My Sip provider doesnt not send DID and I dont know how to configure a DID per trunk.
Outgoing calls works great but incoming calls are not routable because DID is empty.

My pretty default PJSip settings:

Trunk Name: My Cellip
Outboundcallerid: XXXXXXX (My phone number)

Simple
Permanent Auth Rejection: On
Retry Interval: 60
Expiration: 3600
Forbidden Retry Interval: 10
Max Retries: 10
Qualify Frequency: 60
Username: XXXXXXX (Same as phonenumber)
Secret: Password
SIP Server: sip.cellip.com
SIP Server Port: 5060
Outbound Proxy:
Contact User:
Context: from-pstn
Transport:0.0.0.0-udp
Codes: ulaw, alaw, gsm, g726

Where can I enter the DID number? Have tried playing with the Context setting: from-pstn but got no changes

Thanks


(Alex DiMarzo) #2

If your trunk is set up (which it sounds like it is) then enter the DID in Inbound Routes and you should be good to go. This is where all incoming calls land, and they get assigned to extensions/etc through there.


(Roger Östergren) #3

Yes, I have tried that.

But my SIP provider doesnt send DID so it goes
2014-12-18 09:36:09 1418891769.221 0049XXXXXXXXX Hangup s [from-pstn] ANSWERED 00:07

http:// i.imgur.com/xpVincd.png

DID is empty so it goes nowhere.


(Alex DiMarzo) #4

The DID gets registered with your service provider; they point it at your PBX, and when the call comes in, the inbound routes take care of the rest.


(Roger Östergren) #5

I’m aware that using chan_sip it works by sending the register string user:pass@server/IncomingDidNumberXXXXXX but how does it work with PJSip since my Sip provider doesnt return DID? I have tried to enter the DID but DID is blank in the CDR settings no matter what I try.

Is there a setting to force DID on Pjsip?


(Ed Wade) #6

I know this is an 18 month old topic, but I can’t find any info about it anywhere else so where better to post it!

To resolve this, you can set Contact User to the DID number and it then shows the DID in the CDR reports, and allows you to specify the inbound route to send this trunk too.

Hope it helps someone else too!


(Elvis) #7

Mate you are an absolute legend!!!

Just in case anyone needs it as well…

“How to request your provider sends a DID using the pjsip GUI.” -> Put the DID number as the Contact User in pjsip advanced settings.


#8

@edwade Indeed, legend! I was banging my head with this for some time today :slight_smile:


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.