PJSIP TLS over NAT

Has anyone gotten this to work:

I have followed the directions from the wiki: https://wiki.freepbx.org/display/PHON/TLS+and+SRTP

And I cannot get the S705 to use TLS at all. It works with chan sip but not PJSIP. With chansip it works but the Phone Apps BLF’s bug out after 10 minutes… for Example the Find me Follow Me will no longer change to Red when active. But DND still works. I was wondering if that had to do with the Protocol of chan_sip and chan_pjsip.

Known issue with PJSIP and TLS:
https://issues.freepbx.org/browse/FREEPBX-14278

There are basefile edits required to make it work at present.

I am not aware of any BLF issues with chan_sip/TLS and Phone Apps/BLFs

Tried that phone worked for about a day that was that. Went back to chan_sip hints work for the first 10 minutes then they become un-responsive, Follow Me, DND, etc still work just the hints are not updated. This only happens when the phone is registering via TLS. If I change it to UDP it works all the time.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.