PJSIP still has bugs

@BlazeStudios Okay. I understand that. I very well may have it configured on the PBX incorrectly. I provided the logs that were asked for to the best of my ability.

I added the Local Network to sip settings and still no audio. As for the External Media IP… what is that exactly and where do I need to set it?


Seems this might be a bug. Its not only me that is having the exact issue.

That thread was related to a FreePBX bug that was fixed

okay… so maybe its still present in PBXact then possibly. As the other guy mentioned the rtp debug logs seem to be sending traffic to an internal IP and NOT the remote IP. just as mine are above?

Sent RTP packet to (type 00, seq 014477, ts 1110542080, len 000160)
Got RTP packet from (type 00, seq 001609, ts 1110542243, len 000160)

I really dont know. I just need to get this working. I’m reaching for anything.

fwconsole ma list | grep core

core |

You are at the latest version like everyone else. I’m not sure (at this time) if this is a bug or a misconfiguration or a misunderstanding.

Okay should I open a PBXact ticket then? Noone seems to know what is going on. I said I would give it a shot to help you guys out in proving that it does not have issues but clearly something is going on. Chan_SIP works, PJSIP remote no workie.

I dont really know what to get you guys in order to help and all anyone here has to say is… misconfig somewhere. My client is going live next week and this corrected.

Sorry I am trying to help you but you are just going to have to wait at this time for help from anyone. If you open a PBXact ticket they will tell you to use chan_sip. That doesnt mean that there is an internal issue with PJSIP it’s just the team will go with whatever is easier for you as a client to get moving forward.

Eventually we will look into this but for other people it is work fine (outbound and inbound trunks) which is why i tend to lean towards something with your configuration other than jumping into a “this is a pjsip bug”

I know you are. :slight_smile: I’m not whining, just trying to get the importance across that I need to get this working. I cant use chan_sip because these are remote extensions for the same person which is why PJSIP mattered. Would it help if I said not even vmail has voice when trying to access it?

1 Like

It’s been two long years, but this feature (“externhost functionality for PJSIP”) finally seems to be coming!!! Joshua Colp has implemented it (https://gerrit.asterisk.org/#/c/6069/)!

The functionality of using dynamic host addresses for external_media_address and external_signaling_address should therefor soon be available. Looks like Asterisk 14.7.0 and 13.18.0 are the versions that will come with this feature.

From what I understand the refresh time will be configurable in /etc/asterisk/dnsmgr.conf (like the “externrefresh” in chan_sip).

Here is one:
Twilio +SIP/TLS only works on chan_sip, but not on pjsip.

I think it’s premature to call it a bug. But it does look like a tricky configuration.

I am sorry to be the 101th to beat this dead horse (I have no particular beef against pjsip since I have never even used chan_sip), but I feel obligated to report that for a Freepbx install, under

settings / advanced settings / Dialplan and Operational

the comment for the SIP Channel Driver parameter states:

(…) The chan_pjsip channel driver is considered “experimental” with known issues (…)

what he says :slight_smile:

We just haven’t updated this.

What carrier do you use?? I usually use Vitelity but they don’t support PJSIP. I looked at Twilio and I don’t think they do either. I NEED multiple phones on the same extension, it’s the only reason I upgraded FreePBX

So what provider have you found that works with pjsip? I need multiple phones on same extension asappp :frowning:

You can use pjsip on internal extensions, but use chansip for your Sip trunk providers


4 posts were split to a new topic: Multiple lines with PJSIP