PJSIP settings without authetication


(United States) #1

Hello,

My SIP provider did not provider authentication credentials, it is binded to public ip address. Now, we can make outbound calls but does not disconnect when remote user hangup and incoming calls get disconnected in 32 seconds. I am new to this system. How to setup PJSIP settings in Freepbx without authorization.


#2

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. Restart Asterisk if you change them. If you have more than one NIC on the machine, please describe your network setup.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.


(Avayax) #3

What is your pjsip bind port?
If it’s different from 5060 it might be that the provider sends subsequent sip requests like a bye message after a hangup to only port 5060 no matter what port you have in the contact header to which you would normally be expecting sip requests to be sent.


(United States) #4

Hello Sir,

Here is my SIP flow from wireshark for inbound calls.


.

Atten: My SIP provider did not provide us with any sort of authencation. No username and no password. They said that we do not require any credentials so do not know should we used chan sip settings or pjsip settings for trunk.


(United States) #5

hello sir, pjsip is bind to 5060.


#6

The missing ACK from your provider suggests you still have no correctly set your external IP in Asterisk SIP settings. Or possibly, your firewall is blocking the ACK request.


#7

Look at the 200 OK repeatedly sent from the PBX to the provider. The Contact header should contain the PBX IP address (the correct one if it has multiple NICs and the public IP if NAT is involved) and port 5060.

If the above is all good, check that your firewall is not blocking the ACK and there is no SIP ALG in the path.