PJSIP - multiple devices per extension - missed call


When creating a pjsip extension and registering multiple devices to it, they all ring, if the extension is called. But if the call is answered on one of the ringing devices, all others show a missed call.

That’s not a good behavior, because the call has been answered. Turning the missed call logs off, isn’t an option.

Is there a solution for this?

Thank you!

There would be no solution to this because each phone is doing as told. The phone doesn’t know the difference between pjsip or sip. It just got a call and the call was not answered on that endpoint so it is missed.

Some phones support the SIP “Call completed elsewhere” header, to tell the phone that it was actually answered somewhere else. Try adding a lower case ‘c’ to your dial options in Advanced Settings.

Note that the accuracy of this is not all that good, and it can sometimes get confused.

thanks for your help.

Yes, Rob, that is what I am looking for. This seems to be the same way, as it worked with ring groups with the chan_sip driver, isn’t it? Because, that always worked quite well for me.

I’m going to try the dial option “c” next weekend. Hope it does what it should. Because a call, that isn’t answered anywhere, of course should be a “missed call” - on every ringing endpoint.