PJSIP Issue - OBI212 | Configuring Freepbx with PSTN line | PJSIP issue

Hey All,

I have set up an OBi212 with FreePBX to use the PSTN line. It works for outgoing calls but we get an error on incoming calls. The error looks like this:
res_pjsip/ pjsip_distributor.c:676 log_failed_request: Request ‘INVITE’ from ‘<sip:[email protected] .34.xx.xx>’ failed for ‘67. 230.xxx.xxx:5060’ (callid: [email protected] .0.xxx) - No matching endpoint found

I saw many threads with similar issues, some solved, but I have not been able to understand any of those solutions and the things I have been trying have not been working.

If anyone has any suggestions, it would be greatly appreciated

Thank you!

What is your PJSIP configuration and which aspects of the INVITE request were you expecting Asterisk to use to identify the endpoint?

Honestly, I am not sure, I am noob at this but I think it would be a username of sorts. I was following this tutorial but the person used chan_sip htt ps://www.youtube.com/watch?v=xLV4oWpiKTA and I saw that was deprecated.

The video seems to show the gateway on the same LAN as Asterisk. Your log entry seems to show the gateway on the public internet. Are you sure that the INVITE isn’t an unrelated toll fraud attempt.

In any case we can’t tell what is wrong with your configuration without both seeing it an understanding what it was trying to achieve. Given the odd use of addresses, I think we may need quite a bit of detail on your network topology.

Also, there is no way I’m going to trawl through a 20 minute video, relating to hardware I’m never going to use, just to reverse engineer how you configure for the device from a chan_sip configuration buried somewhere in it.

Hi @david55 Yes I am sure. I was getting some fraud attempts earlier than I enabled the firewall and it stopped. I then run asterisk -r command to get a real-time view of what’s happening.

Nothing happens until I make a call to the Landline (POTS). Then I get 4 entries with the error. This is also my own IP address “67. 230.xxx.xxx:5060”.

I understand, I think my issue is more with understanding how pjsip works. I think I am supposed to set up some sort of authentication. I don’t even understand it enough to explain properly so I will go do some reading on pjsip.

Hi All,

I spent a good portion of the night playing with this and solved it. Just to reiterate a bit. I configured my OBi212 following this guide htt ps://wiki.freepbx.org/pages/viewpage.action?pageId=4161594

The guide uses chan_sip and I used chan_pjsip. After everything was configured I could make calls using my POTS which was great, but I could not receive calls. I would get a log error that looks like this log_failed_request: Request ‘INVITE’ from ‘<sip:[email protected] .34.xx.xx>’ failed for ‘67. 230.xxx.xxx:5060 … no matching endpoint found

Solution
Match Inbound Authentication in Trnk > pjsip setting should be set to “Auth Username”.

1 Like

That’s good to hear! If you could post your fixes to the wiki page, that would help others that may have similar issues with that device.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.