PJSIP extensions turn OFFLINE


(Moussa) #1

I upgraded my FreePBX to 15 (Asterisk Version: 13.29.2) over the weekend and I noticed my extensions were going offline. I noticed (so far) this happens after an Apply Configuration OR /var/lib/asterisk/bin/module_admin reload

[2019-12-01 20:41:08] ERROR[2439] res_pjsip.c: Error 171060 'Unsupported transport (PJSIP_EUNSUPTRANSPORT)' sending OPTIONS request to endpoint 201
[2019-12-01 20:41:08] VERBOSE[2439] res_pjsip/pjsip_configuration.c: Endpoint 201 is now Unreachable

In the past, I had Allow Transports Reload set to Yes but Googling PJSIP_EUNSUPTRANSPORT suggests it need to be set to No?

  • Any thoughts?

(John Jarrett) #2

I had the same bahaviour on my 15 box, distro latest version, pjsip extensions, after applying config on a bunch of module updates. Had to reboot to get them back online.


(Joshua C. Colp) #3

You’d want that option set to “no”. If set to “yes” then it is possible during a reload for transports to go away.


(Moussa) #4

Thanks @johnjces and @jcolp. Setting Allow Transports Reload to No seems to prevent dropping the registration. I was surprised this happened now, since this was not an issue with FreePBX 14.


(Joshua C. Colp) #5

It’s a race condition and dependent on the system usage at the time, the reload process, CPU usage, everything.


(Mike Waldron) #6

I just upgraded my client base to 15 from 14, this setting was “No” in 14 apparently and that carried over from the upgrade.

I did however roll out a new system with the 15 ISO and this was set to “Yes” by default, which is how I noticed the same issue you are talking about. I overrode the default to “No”


(Moussa) #7

I hope they will change default to “No”.

Do you have the Outbound CID set at the extension level? When I did the upgrade, the extensions’
Outbound CID disappeared and I was wondering if anyone experienced the same issue?


(Mike Waldron) #8

@moussa854

I checked two of my upgraded systems and the extension caller ID was okay, to answer your question.