PJSIP extension return call after 15 seconds

I have a FreePBX with PJSIP extensions.

When I make a call or a transfer to a extension where are busy or not registered, I hear congestion tone during 15 seconds before the call return to me.

I want to reduce these 15 seconds but I can not find where to change this.

thanks in advance



I want to remark that it is an attended transfer, and that the normal behavior I think it should be that the call immediately return to origin extension, without waiting for 15 seconds.

Can someone help me please? I can not find how to change this behavior.



Can anyone help me?

I do not know if I’ve done the wrong question, or missing data, or I’ve done it in the wrong place. Can someone help me?

I don’t understand your question.

Are you transferring the call using the Transfer button or softkey on your phone? If so, pressing Cancel should get you back to the original caller immediately.

If your device doesn’t have a built-in transfer function and you are using *2 to do an attended transfer, then pressing *1 during the busy tone should get you back to the original caller immediately.

The situation seems unusual in the first place – call waiting, voicemail and follow-me are all disabled?

If the above is not useful, please describe the exact actions you are taking and what goes wrong.

(If you want to change the 15 second timeout, see Attended transfer timeout , but note that this timeout also applies to no-answer, so it’s not a good idea to make it too short.)

1 Like

Thanks for your answer Stewart1.

We use * 2 for the transfer.
Yes, call waiting, voicemail and follow-me are all disabled

Today is a national holiday and I will not be able to prove it until 2018-04-03. Then I will indicate if * 1 solved the problem.
I’m used to chan sip: this same situation ends the call returning instantly.

again thank you very much.

Hello Stewart1,

In the end I found the section “In-Call Asterisk Disconnect Code” in feature code, which at first was configured with ** and did not work. I have reconfigured “In-Call Asterisk Disconnect Code” with a free code and now it works: I can retrieve a call without having to listen to the 15 seconds of congested tone.
That’s how it stays. It still seems strange to me that the call does not automatically return instantly, but this solution is enough for me.

Thank you very very much.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.