PJSIP Endpoints not ringing

We have all our extension set to PJSIP in our FreePBX 13 with Asterisk 13. Some of the extensions ring multiple endpoints as configured in their extension while other will only ring one endpoint. In SIP it was the last registered device but with PJSIP, in the extensions we’re having an issue with, it seems to ring whichever device it wants to ring. I have verified that the extensions are setup the exact same and still not seeing any possible configuration issues.

Here is the show endpoint of on of the extensions I am having issues with.

[[email protected] asterisk]# asterisk -rx "pjsip show endpoint 701"

 Endpoint:  <Endpoint/CID.....................................>  <State.....>  <Channels.>
    I/OAuth:  <AuthId/UserName...........................................................>
        Aor:  <Aor............................................>  <MaxContact>
      Contact:  <Aor/ContactUri..........................> <Hash....> <Status> <RTT(ms)..>
  Transport:  <TransportId........>  <Type>  <cos>  <tos>  <BindAddress..................>
   Identify:  <Identify/Endpoint.........................................................>
        Match:  <ip/cidr.........................>
    Channel:  <ChannelId......................................>  <State.....>  <Time(sec)>
        Exten: <DialedExten...........>  CLCID: <ConnectedLineCID.......>
 =========================================================================================

 Endpoint:  701/701                                              Not in use    0 of inf
     InAuth:  701-auth/701
        Aor:  701                                                5
      Contact:  701/sip:[email protected]:24628;rinstanc 826c683d6a Avail       131.972
      Contact:  701/sip:[email protected]:5060               c60b5bc3e5 Avail         6.613
   Identify:  701-identify/701


 ParameterName                 : ParameterValue
 ====================================================
 100rel                        : yes
 accountcode                   : 
 aggregate_mwi                 : true
 allow                         : (ulaw|g722)
 allow_subscribe               : true
 allow_transfer                : true
 aors                          : 701
 auth                          : 701-auth
 call_group                    : 
 callerid                      : "device" <701>
 callerid_privacy              : allowed_not_screened
 callerid_tag                  : 
 connected_line_method         : invite
 context                       : from-internal
 cos_audio                     : 0
 cos_video                     : 0
 device_state_busy_at          : 0
 direct_media                  : true
 direct_media_glare_mitigation : none
 direct_media_method           : invite
 disable_direct_media_on_nat   : false
 dtls_ca_file                  : 
 dtls_ca_path                  : 
 dtls_cert_file                : 
 dtls_cipher                   : 
 dtls_fingerprint              : SHA-256
 dtls_private_key              : 
 dtls_rekey                    : 0
 dtls_setup                    : active
 dtls_verify                   : No
 dtmf_mode                     : auto
 fax_detect                    : false
 force_avp                     : false
 force_rport                   : true
 from_domain                   : 
 from_user                     : 
 g726_non_standard             : false
 ice_support                   : false
 identify_by                   : username
 inband_progress               : false
 language                      : en
 mailboxes                     : 
 media_address                 : 
 media_encryption              : no
 media_encryption_optimistic   : false
 media_use_received_transport  : false
 message_context               : 
 moh_suggest                   : default
 mwi_from_user                 : 
 named_call_group              : 
 named_pickup_group            : 
 one_touch_recording           : false
 outbound_auth                 : 
 outbound_proxy                : 
 pickup_group                  : 
 record_off_feature            : automixmon
 record_on_feature             : automixmon
 rewrite_contact               : true
 rpid_immediate                : false
 rtp_engine                    : asterisk
 rtp_ipv6                      : false
 rtp_keepalive                 : 0
 rtp_symmetric                 : true
 rtp_timeout                   : 0
 rtp_timeout_hold              : 0
 sdp_owner                     : -
 sdp_session                   : Asterisk
 send_diversion                : true
 send_pai                      : false
 send_rpid                     : false
 set_var                       : 
 srtp_tag_32                   : false
 sub_min_expiry                : 0
 t38_udptl                     : false
 t38_udptl_ec                  : none
 t38_udptl_ipv6                : false
 t38_udptl_maxdatagram         : 0
 t38_udptl_nat                 : false
 timers                        : yes
 timers_min_se                 : 90
 timers_sess_expires           : 1800
 tone_zone                     : 
 tos_audio                     : 0
 tos_video                     : 0
 transport                     : 
 trust_id_inbound              : true
 trust_id_outbound             : false
 use_avpf                      : false
 use_ptime                     : false
 user_eq_phone                 : false

[[email protected] asterisk]# 

If you are using PJSIP extensions, you want to be on Asterisk 13.9.1, are you?

We are currently on asterisk 13.7.2. I will do a yum update asterisk first thing in the a.m. to see if this resolves the issue I am having.

I did a yum update asterisk13 and the “core show version” is still showing the 13.7.2. I am sure I just missed a step but was hoping you could let me know what I forgot. The Installed package shows 13.9.1

Restart asterisk with

fwconsole restart

I did a service asterisk restart but will try the fwconsole.

Don’t do this (unless you know what you’re doing)! Always start and stop asterisk using:

fwconsole start
fwconsole stop
fwconsole restart

With that being said I will refrain from using the service commands any further haha. Thank you for the assistance.

To return to the original issue…

In the extension setup, have you set Contacts to more than 1? (In the advanced tab I think)

I have multiple extensions with multiple Contacts, some extensions function as intended others only ring one device (and it is not always the last logged in)

After updating to 13.9.1, now the CDR log is not showing any calls, we are not able to access voicemail boxes and calls that should go to voicemail are ending.

These are the only errors I see about voicemail in the asterisk log:

[2016-05-23 22:30:58] ERROR[56742][C-00000004]: pbx_functions.c:593 ast_func_read: Function VM_INFO not registered [2016-05-23 22:30:58] WARNING[56742][C-00000004]: func_logic.c:192 acf_if: Syntax IF(<expr>?[<true>][:<false>]) (expr must be no n-null, and either <true> or <false> must be non-null) [2016-05-23 22:30:58] WARNING[56742][C-00000004]: func_logic.c:193 acf_if: In this case, <expr>='', <true>='SUCCESS', and <false>='FAILED'

There was on issue I going to FPBX13 that you may be experiencing. I’ve noticed an issue with NULL in the log.

When I upgraded all the extension recording settings were set to NULL. A subsequent update fixed that, but I had to go and manually put back the settings for each extension to YES as there wasn’t anything selected. My symptoms were that the line hung up as soon as someone picked up the phone.

Check all the settings on one extension that is giving you greif. make sure there is SOMETHING selected for the “multiple choice” settings. Especially the voicemail settings (eg: In voicemail tab, Enabled should be YES or NO, but something should be selected)

These extensions we created in PJSip as we started with asterisk13 and freepbx 13. I have updated to asterisk 13.9.1 per [quote=“lgaetz, post:2, topic:35035”]
you want to be on Asterisk 13.9.1
[/quote]

[[email protected] ~]# asterisk -rx "core show version"
Asterisk 13.9.1 built by mockbuild @ jenkins2.schmoozecom.net on a x86_64 running Linux on 2016-05-13 20:33:39 UTC
[[email protected] ~]# 

I had to completely remove and rebuild the extensions that are giving me issues with the multiple contacts. There seems to be an issue when you bulk import extensions to PJSIP with the ability to ring multiple contacts. Now the issue is resolved with the rebuild.

Did you file a ticket at http://issues.freepbx.org for this?

Once I find the underlying reason I will. Thank you again for all the assistance.

1 Like